Bug 143940 - "service network stop" does not stop all active interfaces
Summary: "service network stop" does not stop all active interfaces
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-02 00:45 UTC by Matthew Saltzman
Modified: 2014-03-17 02:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 20:15:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Saltzman 2005-01-02 00:45:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
"service network stop" stops only interfaces listed in
/etc/sysconfig/network-scripts/ifcfg*.  Other active interfaces (in
particular VMWare's vmnet* interfaces) are not stopped.

This causes apm suspend to leave interfaces up across the suspension
(even with NET_RESTART="yes"), which can break some systems.  In
particular, it causes shutdown/reboot to hang after suspend/resume
when running VMware.

Version-Release number of selected component (if applicable):
initscripts-7.93.5-1

How reproducible:
Always

Steps to Reproduce:
1. "service network start" (e.g., at boot).  Start unconfigured
network interface (e.g., "service vmware start" with vmware networking
configured).
2. "service network stop".
3. "service network status"
    

Actual Results:  Unconfigured active interfaces are still listed as
active.

For example:

# service network status
Configured devices:
lo eth0 eth1
Currently active devices:
vmnet1 vmnet8


Expected Results:  No interfaces listed as active.

Additional info:

See the discussion at
http://www.vmware.com/community/thread.jspa?forumID=19&threadID=9640
for a history of this diagnosis.

Is there a good reason for "service network stop" to only pay
attention to configured interfaces?  Or should stopping the network
really mean stopping *all* network devices?

Comment 1 Bill Nottingham 2005-01-03 06:24:02 UTC
Well, it would require adding random support for other network types
that may not even work to 'correctly' bring it down (who is to say
that if you run 'ip link set <whatever> down' that some daemon won't
bring it back up later)

Why does vmware need a separate initscript for its networking, out of
curiousity?

Comment 2 Matthew Saltzman 2005-01-03 16:43:16 UTC
I wasn't sure how many different ways there might be to get interfaces
up and down, but it turns out that vmware is definitely not standard.

The virtual ethernet modules are inserted and removed by vmware's
initscript along with the VM monitor module.  I don't know if this
could be handled using the usual network-scripts configs and
modprobe.conf, but the program that the initscript invokes to do the
insertion and deletion is a binary, not just a script.

I guess the sensible workaround is something for vmware in
/etc/sysconfig/apm.d then?

Comment 3 Bill Nottingham 2005-01-03 17:49:47 UTC
Probably, yes. And don't forget ACPI. *ducks*

Comment 4 Bill Nottingham 2005-10-03 20:15:46 UTC
Closing this; without specific configuration to handle other device types, it's
not really practical.


Note You need to log in before you can comment on or make changes to this bug.