Bug 143942 - Cannot join wireless network with shared WEP key; orinoco_cs driver
Cannot join wireless network with shared WEP key; orinoco_cs driver
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 20:46 EST by Kevin R. Page
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-01 20:47:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Page 2005-01-01 20:46:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I'm unable to join an 802.11b wireless network which is setup with a
WEP key in shared (vs. open) mode using the orinoco_cs driver.

"restricted\ 12345678" is set as the key through
system-config-network, but the PC is still not admitted to the
network; tweaking settings with iwconfig doesn't have any effect.

In this case it's a Dell Truemobile 1150 mini-PCI card (which is a
re-badged orinoco card) in an IBM X31 Thinkpad.

iwconfig reports that it cannot find the access point (access point is
reported as 44:44:44:44:44:44

The problem seems to be in the orinoco kernel drivers; details can be
found in these posts to the orinoco lists:
http://sourceforge.net/mailarchive/message.php?msg_id=6476623
http://sourceforge.net/mailarchive/message.php?msg_id=5682010
http://sourceforge.net/mailarchive/message.php?msg_id=6505887

Downloading, compiling, and installing version 0.15rc2 of the orinoco
drivers from:
http://www.ozlabs.org/people/dgibson/dldwd/
seems to fix the problem.

These have not yet been merged into the mainline kernel, it would
appear (looks like v0.13d is in the current fedora kernel).


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Set wireless card to join a WEP encrypted network with a shared key
2. Bring wireless device up
3.
    

Actual Results:  PC is unable to join wireless network; it seems as
though it cannot find the access point.

Expected Results:  PC should join the wirless network.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.