Bug 143950 - Directory /etc/gtk-2.0/i686-redhat-linux-gnu should be buildhost-architecture independent
Directory /etc/gtk-2.0/i686-redhat-linux-gnu should be buildhost-architecture...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gtk2 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 10:56 EST by Jos Vos
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 22:53:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2005-01-02 10:56:13 EST
Description of problem:
The directory /etc/gtk-2.0/i686-redhat-linux-gnu is named via
%{_host}, thus it includes the specific architecture of the build host
(e.g., i686), not the base architecture (e.g. i386). Probably, the
directory name should be %{_arch}-%{_host_vendor}-%{_host_os}.

This bug is also related to bug 143547, as librsvg2's %post script
fails, because *there* %{_arch}-%{_host_vendor}-%{_host_os} is used
i.s.o. %{_host}.

Version-Release number of selected component (if applicable):
2.2.4-12
Comment 1 Suzanne Hillman 2005-02-07 16:58:29 EST
Internal RFE bug #147409 entered; will be considered for future releases.
Comment 2 Jens Petersen 2006-06-20 08:58:41 EDT
Other package should be made consistent with gtk2: changing the path
in gtk2 can break other scripts that are currently working, eg for
update-gtk-immodules too.
Comment 3 Matthias Clasen 2007-02-26 22:53:54 EST
The update scripts have been made more tolerant to host mismatches.

Note You need to log in before you can comment on or make changes to this bug.