Bug 1439591 - strange default ordering of partitions
strange default ordering of partitions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blivet-gui (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
:
: 1446923 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-06 05:46 EDT by Pavel Holica
Modified: 2017-05-01 14:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: blivet-gui-2.1.3-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-01 14:15:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot.png (111.63 KB, image/png)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
anaconda.log (101.61 KB, text/plain)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
ifcfg.log (5.40 KB, text/plain)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
packaging.log (14.33 KB, text/plain)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
program.log (64.28 KB, text/plain)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
storage.log (338.31 KB, text/plain)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
storage.state (256.00 KB, application/octet-stream)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details
syslog (652.45 KB, text/plain)
2017-04-06 05:47 EDT, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2017-04-06 05:46:43 EDT
Description of problem:
When I tried to proceed according to test case: http://fedoraproject.org/wiki/QA:Testcase_partitioning_custom_software_RAID in blivet-gui in anaconda, I found, that the ordering of partitions was very strange. I found very problematic to have /boot and /boot/efi as last partitions.

Version-Release number of selected component (if applicable):
anaconda-26.21.1-1.fc26
Fedora-secondary 26 Alpha aarch64

How reproducible:
always

Steps to Reproduce:
1. http://fedoraproject.org/wiki/QA:Testcase_partitioning_custom_software_RAID

Actual results:
/boot and /boot/efi are on last partitions, it's not possible to change ordering

Expected results:
/boot and /boot/efi are on first partitions

Additional info:
It would be very good to have ability to change ordering of partitions manually, but that seems to be more like big RFE in current situation.
Comment 1 Pavel Holica 2017-04-06 05:47 EDT
Created attachment 1269285 [details]
screenshot.png

Forgot to attach screenshot.
Comment 2 Pavel Holica 2017-04-06 05:47:29 EDT
Created attachment 1269286 [details]
anaconda.log
Comment 3 Pavel Holica 2017-04-06 05:47:32 EDT
Created attachment 1269287 [details]
ifcfg.log
Comment 4 Pavel Holica 2017-04-06 05:47:35 EDT
Created attachment 1269288 [details]
packaging.log
Comment 5 Pavel Holica 2017-04-06 05:47:39 EDT
Created attachment 1269289 [details]
program.log
Comment 6 Pavel Holica 2017-04-06 05:47:42 EDT
Created attachment 1269290 [details]
storage.log
Comment 7 Pavel Holica 2017-04-06 05:47:46 EDT
Created attachment 1269291 [details]
storage.state
Comment 8 Pavel Holica 2017-04-06 05:47:50 EDT
Created attachment 1269292 [details]
syslog
Comment 9 Pavel Holica 2017-04-06 07:39:42 EDT
This is also issue for x86_64 with UEFI.
Comment 10 Fedora Update System 2017-04-24 15:34:10 EDT
blivet-gui-2.1.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2fbb5d0e82
Comment 11 Fedora Update System 2017-04-25 17:29:13 EDT
blivet-gui-2.1.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2fbb5d0e82
Comment 12 Vojtech Trefny 2017-04-30 11:10:49 EDT
*** Bug 1446923 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2017-05-01 14:15:30 EDT
blivet-gui-2.1.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.