Bug 143960 - wireless tools should use v17
wireless tools should use v17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-01-02 13:12 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 16:31:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-01-02 13:12:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) KHTML/3.3.2 (like Gecko)

Description of problem:
Kernel 2.6.10 is updated to V17 of Wireless Extension. Thus the wireless
drivers are compiled with that. This results in warnings etc in system-config-
network via rhpl. I am also filing a report with glibckernheaders which should
be updated as well.

Version-Release number of selected component (if applicable):
wireless-tools

How reproducible:
Always

Steps to Reproduce:
1.update to FC4 with 2.6.10
2.start using a wireless driver
3.system-config-network
    

Additional info:
Comment 1 Dan Williams 2005-01-17 16:27:15 EST
wireless-tools-28.pre4 has been built into rawhide and fc3-updates,
FYI.  Does that help the problem at all?
Comment 2 Sammy 2005-01-17 20:35:04 EST
I don't see it ! 
Comment 3 Sammy 2005-01-17 20:50:01 EST
O.K. I got it from fc3. In the spec file there is a def that sais  =16 
I don't think it has any effect. I made it 17 and rebuilt. It seem ok. 
I'll test it a bit more. Of course this does not fix the rhpl dependence 
on the version 16 through glibc-kernheaders which contains wireless.h 
for Version 16. 
Comment 4 Péter, Soós 2005-01-24 04:47:31 EST
You should update Fedora Core 2 too.

iwconfig reports the following after kernel update to 2.6.10-1.9_FC2:

Warning: Driver for device eth1 has been compiled with version 17
of Wireless Extension, while this program is using version 16.
Some things may be broken...
Comment 5 Dan Williams 2005-03-12 15:46:22 EST
than: I believe that kdenetwork depends on wireless-tools too, so it would need to be 
updated in FC2 were I to update wireless-tools to v28.  Is this correct?
Comment 6 Dan Williams 2005-03-12 15:47:31 EST
than: and by update, I only mean recompile against the new wireless-tools since they two 
are ABI compatible except for the change from "libiw.so.27" -> "libiw.so.28".
Comment 7 Ngo Than 2005-03-13 05:43:13 EST
yes, kdenetworks needs to be rebuilt against new wireless-tools in
this case
Comment 8 jim 2005-04-01 09:42:36 EST
I also get the 
"Warning: Driver for device eth1 has been compiled with version 17
of Wireless Extension, while this program is using version 16.
Some things may be broken..." 
 
 installed 
wireless-tools-27-0.pre25.3
2.6.10-1.770_FC3
NetworkManager-gnome-0.3.4-1.1.0.fc3
NetworkManager-0.3.4-1.1.0.fc3

I have kept this PC updated So why the error?
Comment 9 Dan Williams 2005-04-01 09:47:22 EST
The wireless-tools package needs to be updated, and then kdenetwork,
NetworkManager, and system-config-network all need to be recompiled to match. 
The issue is that updated kernels include later versions of wireless extensions
but wireless-tools doesn't match that version.
Comment 10 Dan Williams 2005-05-04 16:31:20 EDT
A wireless-tools for FC3 was pushed which should fix this issue...

wireless-tools-27-2.2.0.fc3

Note You need to log in before you can comment on or make changes to this bug.