Bug 1439673 - meshlab fails to install: nothing provides libGLEW.so.1.13()(64bit) needed by meshlab-1.3.2-10.fc25.x86_64
Summary: meshlab fails to install: nothing provides libGLEW.so.1.13()(64bit) needed by...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: meshlab
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1423936
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-06 11:55 UTC by Dr. David Alan Gilbert
Modified: 2017-07-23 00:22 UTC (History)
4 users (show)

Fixed In Version: meshlab-1.3.2-13.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-20 15:54:25 UTC


Attachments (Terms of Use)

Description Dr. David Alan Gilbert 2017-04-06 11:55:03 UTC
Description of problem:
sudo yum install meshlab
Last metadata expiration check: 0:01:57 ago on Thu Apr 06 12:47:20 2017 BST.
Error: 
 Problem 1: cannot install the best candidate for the job
  - nothing provides libGLEW.so.1.13()(64bit) needed by meshlab-1.3.2-10.fc25.x86_64
 Problem 2: conflicting requests
  - nothing provides libGLEW.so.1.13 needed by meshlab-1.3.2-10.fc25.i686
  - nothing provides libGLEW.so.1.13()(64bit) needed by meshlab-1.3.2-10.fc25.x86_64

it looks like libGLEW is now 2.0.0-2 and we're hitting that it doesn't rebuild (bz 1423936) bug 1161846 suggests importing a newer meshlab - not sure if that would help or not.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Miro Hrončok 2017-07-11 11:23:26 UTC
The rebuild for GLEW failed on ppc64 arches in January and nobody fixed that.

I will exclude those arches to make meshlab available at least on others.

Comment 2 Miro Hrončok 2017-07-11 11:37:48 UTC
Note that rawhide build fails on all arches now :(

Comment 3 Miro Hrončok 2017-07-11 11:40:29 UTC
Also on F26.

Might be easier to update as per bz1161846

Eric, care to say something on the matter?

Comment 4 Bert DeKnuydt 2017-07-13 09:34:50 UTC
Not a solution of course, but a workaround:

> ln -s /usr/lib64/libGLEW.so.2.0 /usr/lib64/libGLEW.so.1.13

does make Meshlab work again somewhat on F26.

Anyhow, updating is really due...

Comment 5 Fedora Update System 2017-07-19 09:20:27 UTC
meshlab-1.3.2-13.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0b8de14b0d

Comment 6 Fedora Update System 2017-07-20 00:26:24 UTC
meshlab-1.3.2-13.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0b8de14b0d

Comment 7 Fedora Update System 2017-07-20 15:54:25 UTC
meshlab-1.3.2-13.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Dr. David Alan Gilbert 2017-07-23 00:22:43 UTC
Thanks, meshlab-1.3.2-13.fc26.x86_64 works nicely.


Note You need to log in before you can comment on or make changes to this bug.