Bug 1439684 - system is not booting after creating partition without creating swap partition.
system is not booting after creating partition without creating swap partition.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: blivet-gui (Show other bugs)
26
i586 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-06 07:58 EDT by Saurabh Thakre
Modified: 2017-06-13 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-13 12:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this png file will tell that what happpened when the system is going to boot showing this error. (59.05 KB, image/png)
2017-04-06 07:58 EDT, Saurabh Thakre
no flags Details

  None (edit)
Description Saurabh Thakre 2017-04-06 07:58:58 EDT
Created attachment 1269363 [details]
this png file will tell that what happpened when the system is going to boot showing this error.

Description of problem:
After installing fedora 26 with by LVM without swap partition,the system is not booting. 

Version-Release number of selected component (if applicable):


How reproducible:easy

Steps to Reproduce:
     1.Boot the installer using any available means.
    2.Proceed to the installer's main screen, making sensible choices, and enter the Installation Destination screen.
    3.Ensure only the single target device you prepared is selected as the installation target disk.
    4.Ensure the option to configure partitioning yourself is selected, and complete this screen.
    5.On the MANUAL PARTITIONING screen, delete all existing partitions (if any).
    6.Click the Click here to create them automatically link
    7.Delete the swap partition that is automatically created
    8.Complete the installation process, making sensible selections for all other installer options.
    9.Boot the installed system. 
Actual results:
not booting

Expected results:
The install process should complete successfully and the installed system.should boot as expected.
No swap partition should be in use (you can check /proc/swaps) 

Additional info:
Comment 1 Vojtech Trefny 2017-06-13 12:59:16 EDT
Hi, thank you for the  report and for testing blivet-gui and sorry I forgot to reply to this.

I'm closing this bug -- there were some issues with kernel when running Fedora 26 Alpha and this definitely looks like the same issue. This shouldn't be related to blivet-gui. If you see this again, feel free to reopen this. Thank you again.

Note You need to log in before you can comment on or make changes to this bug.