Bug 143976 - Anaconda gives errors while trying to install
Anaconda gives errors while trying to install
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-01-02 22:45 EST by peter gahzinia
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description peter gahzinia 2005-01-02 22:45:05 EST
Description of problem: Anaconda gives errors in a dialog box: 
Assertion (heads < 256) at disk_dos.c:486 in function
probe_partition_for_geom() failed

Assertion ((C * heads + H) * sectors + S == A) at disk_dos.c:495 in
function prob_partition_for_geom() failed

It does that a couple of times throughout the install, and I can hit
ignore and continue on. At the last step, it crashes and says I can
write the log file to a floppy, I insert a floppy, hit ok, it says it
is writing, but never writes anything.

The error it gives that I can write to the floppy is:
traceback(most recent call last)
file "usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py" line
1074 in handle render callback

line 242 in renderCallback

Version-Release number of selected component (if applicable): Fedora
Core 3

How reproducible: every time. I did the check your cd test at the
beginning, at it says it passed. I checked the md5sum of the iso image
I downloaded that checked out. 

Steps to Reproduce:
1.Insert cd
2.power on computer
3.try to install fc3
Actual results:
The error messages I detailed above.

Expected results:
Fedora Core 3 to be installed.

Additional info:
I have two hard drives. On the 40 gig (master), I have a 10 gig linux
partition, a 500 meg swap, and a 33 gig win2k partition. On the other
drive - slave - it is a storage drive for win2k. Currently, Libranet
is installed on the 10 gig partition. I remember using Power Quest
Partition Magic trying to resize the linux partition to be larger and
the win2k to smaller, and on the reboot, when Partition Magic went to
do the resizing, I would get an error about the drive geometry being
incorrect, so the process couldn't be completed. Is it possible that
there is a problem with the 40 gig drive? Aside from what I described
here, I haven't had any problems with it, and Libranet has not given
me any problems with drive geometry. 

If this bug/problem/issue is confusing, I can try to reinstall again
and make sure that I have the errors written down correctly.

Any and all input is greatly appreciated.
Comment 1 Jeremy Katz 2005-01-02 23:25:36 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.