Bug 143977 - system-config-printer does not parse /usr/lib/cups/backend/*
Summary: system-config-printer does not parse /usr/lib/cups/backend/*
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-03 05:57 UTC by Ignacio Vazquez-Abrams
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 09:18:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ignacio Vazquez-Abrams 2005-01-03 05:57:21 UTC
When creating a queue in system-config-printer it doesn't parse
/usr/lib/cups/backend/* for what backends are available. Instead it
just blithely assumes that "Locally-connected", "Networked CUPS
(IPP)", "Networked UNIX (LPD)", "Networked Windows (SMB)", "Networked
Novell (NCP)", and "Networked JetDirect" are the only options, and are
always available. This causes an issue if additional backends such as
CUPS-PDF are installed because s-c-p completely ignores the additional
backends.

Comment 1 Tim Waugh 2005-01-04 09:18:27 UTC
This is as designed.  Printconf needs throwing out and redoing from scratch IMHO.


Note You need to log in before you can comment on or make changes to this bug.