Bug 1439772 - Neutron lbaas tests are skipped although lbaas is installed and enabled
Summary: Neutron lbaas tests are skipped although lbaas is installed and enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Jakub Libosvar
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-06 13:46 UTC by Arie Bregman
Modified: 2019-09-10 14:12 UTC (History)
5 users (show)

Fixed In Version: openstack-neutron-lbaas-10.0.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:18:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 454679 None None None 2017-04-07 11:32:08 UTC
Launchpad 1651012 None None None 2017-04-07 11:32:39 UTC

Description Arie Bregman 2017-04-06 13:46:20 UTC
Description of problem:

The following neutron lbaas tests are skipped even though lbaas is installed and the extension included in tempest conf:

https://github.com/openstack/neutron-lbaas/blob/master/neutron_lbaas/tests/tempest/v2/api/test_load_balancers_non_admin.py#L24

This is what we see in the logs:

<testcase classname="" name="setUpClass (neutron_lbaas.tests.tempest.v2.api.test_health_monitor_admin.TestHealthMonitors)" time="0.000">
<skipped>lbaas extension not enabled.</skipped>
</testcase>
<testcase classname="" name="setUpClass (neutron_lbaas.tests.tempest.v2.api.test_listeners_admin.ListenersTestJSON)" time="0.000">
<skipped>lbaas extension not enabled.</skipped>
</testcase>
<testcase classname="" name="setUpClass (neutron_lbaas.tests.tempest.v2.api.test_load_balancers_admin.LoadBalancersTestAdmin)" time="0.000">
<skipped>lbaas extension not enabled.</skipped>
</testcase>
<testcase classname="" name="setUpClass (neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON)" time="0.000">
<skipped>lbaas extension not enabled.</skipped>
</testcase>

Version-Release number of selected component (if applicable): OSP 11


How reproducible: 100%


Steps to Reproduce:
1. Deploy OSP 11 (Director) + LBaaS
2. Run neutron lbaas tests
3.

Actual results: Neutron lbaas tests are skipped


Expected results: Neutron lbaas tests should run

Comment 4 Eran Kuris 2017-04-19 06:34:31 UTC
Fix verified : 
openstack-neutron-lbaas-10.0.0-7.el7ost.noarch

Comment 5 errata-xmlrpc 2017-05-17 20:18:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.