Bug 1439787 - [spec] remove systemd-sysusers manpages
Summary: [spec] remove systemd-sysusers manpages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-06 14:15 UTC by David Kupka
Modified: 2019-01-18 05:29 UTC (History)
6 users (show)

Fixed In Version: systemd-219-36.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:14:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2297 normal SHIPPED_LIVE systemd bug fix and enhancement update 2017-08-01 12:40:16 UTC

Description David Kupka 2017-04-06 14:15:53 UTC
Description of problem:
systemd package contains only manual pages for systemd-sysusers but binary, service file and directory is missing.


Version-Release number of selected component (if applicable):
systemd-219-32.el7.x86_64


How reproducible:
always


Steps to Reproduce:
1. # rpm -ql systemd | grep systemd-sysusers
2. # ls -ld $(pkg-config --variable sysusersdir systemd)

Actual results:

/usr/share/man/man8/systemd-sysusers.8.gz
/usr/share/man/man8/systemd-sysusers.service.8.gz

ls: cannot access /usr/lib/sysusers.d: No such file or directory


Expected results:

/usr/bin/systemd-sysusers
/usr/lib/systemd/system/sysinit.target.wants/systemd-sysusers.service
/usr/lib/systemd/system/systemd-sysusers.service
/usr/share/man/man8/systemd-sysusers.8.gz
/usr/share/man/man8/systemd-sysusers.service.8.gz

drwxr-xr-x. 2 root root 4096 Apr  6 15:00 /usr/lib/sysusers.d


Additional info:

Comment 2 Lukáš Nykrýn 2017-04-06 14:22:16 UTC
We don't want to support sysusers in rhel so I guess we should remove those manpages as well.

Comment 3 David Kupka 2017-04-07 05:28:17 UTC
What is the reason to not support this IMO very useful feature in rhel? Is this information available somewhere publicly? Also why is the version of systemd package in rhel 219 when is doesn't contain feature from upstream version 215?

Comment 4 Lukáš Nykrýn 2017-04-10 08:39:02 UTC
The initial version of systemd in rhel7 was 208 and we did a rebase in 7.2 to 219. The rebase was not about bringing new features, but mainly to have more maintanable code. The upstream moved from libdbus to sd-bus after 208 and backports were a nightmare for us. We have tried to pack the 219 so it would look as close as possible to the 208. That included removal of sysuser, because we wanted to avoid customers screaming "Hey there is something new that adds users to my systems and we need to change our internal guidelines because of that!"

The second reason was, that back then this was not properly tested in Fedora and if I am not mistaken it still is not.

And the third reaons is that we did not get any use-cases for this feature and till now nobody complained that it is missing.

I am not against adding it to rhel, but first I would like to either see requests from customers or a plan why we need it in rhel.

Comment 8 errata-xmlrpc 2017-08-01 09:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2297


Note You need to log in before you can comment on or make changes to this bug.