Bug 143984 - yum update fails to download headers through proxy
yum update fails to download headers through proxy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 06:27 EST by Davide Bolcioni
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 06:13:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2005-01-03 06:27:35 EST
Description of problem: when attempting 'yum update' with http_proxy
and https_proxy set, 'yum list updates' works but 'yum update' fails
with '[Error -1] Header is not complete' for all mirrors in
distributed mirrorlist. Unset *_proxy and it works fine; FC1 hosts on
the same network operate through the same proxy without a hitch.

Version-Release number of selected component (if applicable): yum-2.1.11-3


How reproducible: always.


Steps to Reproduce:
1. install FC1 on a gateway
2. install squid on the gateway
3. install FC3 behind the gateway
4. upgrade FC3 without the proxy up to before the RPM below
5. set *_proxy to address squid on the gateway
6. try 'yum update'
  
Actual results: [Error -1] Header is not complete for
selinux-policy-targeted-1.17.30-2.62


Expected results: update of the aboce


Additional info: the yum output is somewhat confusing
Setting up Update Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2622/2622
updates-re: ################################################## 407/407
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for selinux-policy-targeted to pack into
transaction set.
selinux-policy-targeted-1 100% |=========================|  64 kB    00:00
http://fr2.rpmfind.net/linux/fedora/core/updates/3/i386/selinux-policy-targeted-1.17.30-2.62.noarch.rpm:
[Errno -1] Header is not complete.
Trying other mirror.
selinux-policy-targeted-1 100% |=========================|  64 kB    00:00
http://ftp.ndlug.nd.edu/pub/fedora/linux/core/updates/3/i386/selinux-policy-targeted-1.17.30-2.62.noarch.rpm:
[Errno -1] Header is not complete.

as it seems to be downloading the RPM instead of the header, and the
squid log confirms this:

1104750845.754   3494 10.17.61.46 TCP_MISS/200 65861 GET
http://fr2.rpmfind.net/linux/fedora/core/updates/3/i386/selinux-policy-targeted-1.17.30-2.62.noarch.rpm
- DIRECT/195.220.108.108 application/x-rpm
Comment 1 Davide Bolcioni 2005-01-05 12:46:30 EST
Sorry, my mistake. The gateway is multihomed and the value of *_proxy
was not correct; wget got it right because the appropriate value was
in /etc/wgetrc.
Comment 2 Davide Bolcioni 2005-01-05 12:53:30 EST
Sorry again, too eager. Even with the correct proxy, new headers get
[Error -1] Header is not complete.
Comment 3 Seth Vidal 2005-01-05 13:06:07 EST
does your proxy not support byte-ranges?
Comment 4 Davide Bolcioni 2005-01-07 06:13:25 EST
Great suggestion: the squid.conf was too paranoid and overused
header_access, silently strangling byte range functionality. Allowing
through the appropriate HTTP/1.1 headers did the trick. Thank you very
much.

Note You need to log in before you can comment on or make changes to this bug.