Bug 1439880 - Attempt to unlink a directory with children produces a hang
Summary: Attempt to unlink a directory with children produces a hang
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: Ramakrishnan Periyasamy
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-06 18:18 UTC by Matt Benjamin (redhat)
Modified: 2017-07-30 16:03 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:31:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 19435 None None None 2017-04-06 18:18 UTC

Description Matt Benjamin (redhat) 2017-04-06 18:18:58 UTC
Description of problem:

Attempt to unlink a directory with children produces a hang due to a missing unlock before returning errcode from unlink


How reproducible:
100%


Steps to Reproduce:
1. mkdir /mnt/dir1
2. touch /mnt/dir1/file1
3. rmdir /mnt/dir1
rmdir: failed to remove ‘/mnt/dir1’: Directory not empty
4. ls /mnt <-- hung


Additional info:
Backport prepped.

Comment 7 errata-xmlrpc 2017-06-19 13:31:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.