Bug 1439895 - NetApp Cinder back end does not deploy in OSP-11
Summary: NetApp Cinder back end does not deploy in OSP-11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Alan Bishop
QA Contact: Tzach Shefi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-06 19:19 UTC by Alan Bishop
Modified: 2018-06-02 01:43 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-7.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-05-17 20:18:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 456264 None None None 2017-04-12 15:41:52 UTC
Launchpad 1680568 None None None 2017-04-06 19:19:09 UTC

Description Alan Bishop 2017-04-06 19:19:10 UTC
Description of problem:

It's not possible to deploy a NetApp back end for Cinder in OSP-11 (Ocata). The hieradata (/etc/puppet/hieradata/cinder_netapp_data.json) is malformed, and none of the relevant settings appear in the driver portion of /etc/cinder/cinder.conf.

Other Cinder back end drivers (Dell EMC Ps, SC and ScaleIO) have been converted for composable roles, but the NetApp driver has not been converted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy an overcloud using an environment file that enables the NetApp Cinder back end
2.
3.

Actual results:

The back end is not enabled (valid settings do not appear in the back end driver section of /etc/cinder/cinder.conf

Expected results:


Additional info:

Comment 1 Paul Grist 2017-04-07 16:33:51 UTC
Good catch here.  I don't think we have anything solid in place to catch this for partners that have added OOO deployment for at least Cinder.  Is there any way to check if there are other similar issues to catch now in the OSP11/ocata?

Comment 2 Red Hat Bugzilla Rules Engine 2017-04-07 16:44:26 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 4 Emilien Macchi 2017-04-07 16:52:58 UTC
Paul, no we currently don't have upstream CI jobs that test netapp and other vendors integration in TripleO.

Comment 5 Alan Bishop 2017-04-07 17:08:29 UTC
I think I can help out with this.

Comment 6 Christian Schwede (cschwede) 2017-04-12 15:41:53 UTC
Merged on master, proposed backport: https://review.openstack.org/#/c/456264/

Comment 7 Alan Bishop 2017-04-13 16:13:24 UTC
Backport to stable/ocata is stuck due to upstream bug that is blocking CI (https://bugs.launchpad.net/tripleo/+bug/1682001)

When it lands lands in stable/ocata, will it need to be explicitly backported to OSP-11 or will/can it be picked up by the next rebase?

Comment 8 Christian Schwede (cschwede) 2017-04-21 06:47:39 UTC
Upstream patch just merged. Moving to POST.

Comment 9 Alan Bishop 2017-04-24 18:22:07 UTC
Note to QE:

Please be sure to focus on the OSP-10 to OSP-11 upgrade path. See my note to
the Doc team for details.

Note to Doc team:

Section 3.4.2 of the upgrade document [1] covers situations where the customer
is deploying modified overcloud templates, and section 3 of the NetApp Block
Storage Back End Guide [2] directs the operator to do just that.

In order to successfully upgrade OSP-10 to OSP-11 with a NetApp back end, the
customer will need to sync their modified version of
environments/cinder-netapp-config.yaml with the new version in OSP-11.

Specifically, they need to _replace_ this line (applicable in OSP-10):

  OS::TripleO::ControllerExtraConfigPre: ../puppet/extraconfig/pre_deploy/controller/cinder-netapp.yaml

With this (applicable in OSP-11):

  OS::TripleO::Services::CinderBackendNetApp: ../puppet/services/cinder-backend-netapp.yaml

The guide [2] explains the path to the .yaml file needs to be updated from a
relative path ("../puppet") to an absolute path. This applies to the new
cinder-backend-netapp.yaml file in OSP-11.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/upgrading_red_hat_openstack_platform/
[2] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/netapp_block_storage_back_end_guide/index

Comment 11 Alan Bishop 2017-05-16 14:10:22 UTC
The doc notes I outline in comment #9 are being incorporated into the overall upgrade documentation.

Comment 12 errata-xmlrpc 2017-05-17 20:18:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.