Bug 1439943 - [RFE] increase timeout of spacewalk-debug portion of sosreport
Summary: [RFE] increase timeout of spacewalk-debug portion of sosreport
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.9
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 6.10
Assignee: Filip Krska
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks: 1461138 1440091 1506659 1572198
TreeView+ depends on / blocked
 
Reported: 2017-04-06 22:50 UTC by Candace Sheremeta
Modified: 2020-09-10 10:26 UTC (History)
17 users (show)

Fixed In Version: sos-3.2-59.el6
Doc Type: Bug Fix
Doc Text:
Cause: Collection of spacewalk-debug logs may take longer than default timeout. Consequence: Sosreport collection fails with timeout. Fix: Timeout for spacewalk-debug logs collection is increased to 15 minutes. Result: Chances of timeout expiration for spacewalk-debug logs collection are significantly lower.
Clone Of:
: 1440091 1572198 (view as bug list)
Environment:
Last Closed: 2018-06-19 05:23:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3177961 None None None 2018-02-28 14:35:17 UTC
Red Hat Product Errata RHBA-2018:1920 None None None 2018-06-19 05:24:18 UTC

Description Candace Sheremeta 2017-04-06 22:50:57 UTC
What is the nature and description of the request?
currently the spacewalk-debug portion of the sosreport command is set to time out after 300 seconds. this poses an issue for satellite servers that have a large amount of data to generate with the spacewalk-debug. we would like to increase this timeout

Why does the customer need this? (List the business requirements here)
it would make supporting our customers that much easier (also, the customers are generally uneasy when they see the sosreport throw a timeout error)

How would the customer like to achieve this? (List the functional requirements here)
mmello++ has written an upstream patch for this enhancement: https://github.com/spacewalkproject/spacewalk/pull/532

For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
we have successfully reproduced the issues on internal servers, so we can test on the same when the patch is backported

List any affected packages or components.
sosreport, spacewalk-debug

Would the customer be able to assist in testing this functionality if implemented?
yes

Comment 1 Candace Sheremeta 2017-04-06 22:55:36 UTC
my apologies, upstream patch is here:
https://github.com/sosreport/sos/pull/989/commits/c0a8aaca6ba01e8cfde8bc18ad30cf3849f6b2bf

Comment 14 errata-xmlrpc 2018-06-19 05:23:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1920


Note You need to log in before you can comment on or make changes to this bug.