Bug 143998 - Bonding problem: change the assignment of the non slave ethernet interfaces
Bonding problem: change the assignment of the non slave ethernet interfaces
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 143999 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 11:17 EST by celine
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-22 11:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description celine 2005-01-03 11:17:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
T312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
The bonding is configured on the ethernet interface eth2 and eth3. 
After rebooting, the MAC ADDRESS of the master interface is the one 
of eth0. The MAC address of eth0 is also become the one of eth2...

Please could you help me??

My redhat release is RHEL ES 3.0 U2.

Thanks 

Version-Release number of selected component (if applicable):
initscripts-7.31.13.EL-1

How reproducible:
Always

Steps to Reproduce:
1. Configure eth2 and eth3 as slave interfaces
2. Reboot
3.
    

Actual Results:  MAC address of the MASTER interface is the one of 
eth0

Expected Results:  MAC address of the MASTER interface is the one of 
eth2 or eth3

Additional info:

My redhat release is RHEL ES 3.0 U2.
Comment 1 Bill Nottingham 2005-01-03 12:51:00 EST
Please install a more recent package and try again. 7.31.18.EL is the
latest.

Comment 2 Bill Nottingham 2005-01-03 12:51:33 EST
*** Bug 143999 has been marked as a duplicate of this bug. ***
Comment 3 celine 2005-01-03 13:34:36 EST
It seems that by adding the MAC address in the file of configuration 
of the slave interfaces (HWADDR) corresponding to the interfaces; it 
works fine. Do you know if do that is correct? 
Comment 4 Bill Nottingham 2005-01-03 15:51:45 EST
If your modules are loaded in a different order than the interfaces
(or different than the probe order of the driver), yes, you need
HWADDR to correctly assign the device name.
Comment 5 celine 2005-01-04 02:44:19 EST
Is there a problem to put the initial MAC Address in the 
configuration files of the slave interface whereas the slave 
interfaces MAC address is normally the same after the bonding? (There 
is also a different MAC address in the configuration file of the 
slave interface and the command ifconfig -a for one slave interface)
Comment 6 Bill Nottingham 2005-01-04 13:08:27 EST
HWADDR is a property of the hardware device used to identify which
card is a slave before setting up the bonding device; it would be
more-or-less expected for it to be different than the address that
ends up on the bonding device.
Comment 7 Bill Nottingham 2005-02-22 11:47:55 EST
Closing that it works as expected, based on comment #3.

Note You need to log in before you can comment on or make changes to this bug.