Bug 1440110 - Midnight Command 4.8.19 has broken keymapping for Copy & Move
Summary: Midnight Command 4.8.19 has broken keymapping for Copy & Move
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1439886 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-07 10:12 UTC by Ali Akcaagac
Modified: 2017-12-12 15:37 UTC (History)
12 users (show)

Fixed In Version: mc-4.8.19-2.fc26 mc-4.8.19-2.fc25 mc-4.8.19-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-09 21:24:50 UTC


Attachments (Terms of Use)

Description Ali Akcaagac 2017-04-07 10:12:39 UTC
The new package mc-1:4.8.19-1.fc26.x86_64 has broken keymapping for Copy & Paste.

The correct order:

F5 = Copy
F6 = Move

Shift + F5 = Copy As
Shift + F6 = Move As

With the new Release (4.8.19):

F5 = Copy
F6 = Move

Shift + F3 = Copy As
Shift + F4 = Move As

This sadly overwrites the Shift + Fx commands for F3 and F4 and looks like a bug (and a nasty one) to me. People using midnight commander for (10+ years) by accident are going to hit the wrong keycombos now and force reactions that usually shouldn't happen. The new keymapping (which looks like an accidental bug to me) are also not aligned with the Text written inside the Keybar.

This misebhaviour is also valid if you compare mc under XOrg and using it under Console. The keysmapping are kinda wrong...

Comment 1 Ali Akcaagac 2017-04-07 11:14:22 UTC
Shift + F6 which used to be "Move As" now deletes files. Bad if someone has "delete confirmation" disabled. An operation that used to be "Move As" with dialog and feedback turns out to become "delete" without feedback (if confirmation was disabled". This is a huge regression that may lead to fatal misbehaviour AND possible and not intended data loss.

Comment 2 Ali Akcaagac 2017-04-07 19:01:50 UTC
I opened a bugreport at:

http://midnight-commander.org/ticket/3807

... and figured out that the issue is related by the switch from "slang" to "ncurses".

NCurses somehow misaligns the Fx Keys (in combination with Shift, Alt, Ctrl) to other keys.

You can find more information in the ticket above... Also related another ticket...

http://midnight-commander.org/ticket/3254

The problem really is, that NCurses misaligns the Fx Keys to other Fx Keys and thus causing midnight commander to execute other operations that expected. This issue also causes Fx Keys that had a different function to now do something totally differently (overwriting the function).

So either there is an issue with NCurses or it might be necessary to switch back from ncurses to slang. Otherwise midnight commander's functionality stays broken...

Comment 3 Pavel Roskin 2017-04-07 20:28:19 UTC
*** Bug 1439886 has been marked as a duplicate of this bug. ***

Comment 4 Pavel Roskin 2017-04-07 20:50:55 UTC
Please note that mc compiled with ncurses cannot use "Learn Keys" to redefine keys. The keys are captured correctly, but take not effect. I believe mc can do raw input with ncurses when learning keys. However, ncurses is allowed to process keys when no learning keys.

I agree that mc should switch from F1x notation to Shift-Fx. F15 is "local copy" because F15 is Shift-F5, and F5 is "copy". Interpreting F15 as Shift-F3 breaks that natural connection.

I believe the ncurses support in mc has never been on by default, so it's less tested. If the Fedora mc maintainers insist on using ncurses, they should patch mc to treat Shift-Fn as F(10+n).

Comment 5 vvs 2017-04-09 17:10:54 UTC
This is exactly the same bug which existed years ago. Unfortunately, I can't find it in bugzilla right now. It's very sad that regression testing is non-existent in mc and it's always in a state of permanent brokenness, trading one bug for another.

Comment 6 Ali Akcaagac 2017-04-09 18:15:55 UTC
(In reply to vvs from comment #5)
> This is exactly the same bug which existed years ago.

This is more a bug in ncurses and the way mc is using it. But the regression appeared because the fedora maintainer chose to change slang to ncurses in the configure options. Please read more about it here:

https://bugzilla.redhat.com/show_bug.cgi?id=1436394

The issue has been reverted but the new spec hasn't been committed to git.

Comment 7 vvs 2017-04-09 20:12:39 UTC
Sorry, I wasn't finger-pointing to anybody. Shit happens and more often than not it's in a foreign libraries.

What I meant was that mc desperately needs a regression test suite more than anything else. Especially, when such a bug can be traced to as long ago as https://bugzilla.redhat.com/show_bug.cgi?id=1389 Otherwise it's doomed to repeat again and again.

Comment 8 Jaroslav Škarvada 2017-04-11 15:59:37 UTC
(In reply to Ali Akcaagac from comment #6)
> (In reply to vvs from comment #5)
> > This is exactly the same bug which existed years ago.
> 
> This is more a bug in ncurses and the way mc is using it. But the regression
> appeared because the fedora maintainer chose to change slang to ncurses in
> the configure options. Please read more about it here:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1436394
> 
> The issue has been reverted but the new spec hasn't been committed to git.

Yes, it's still not in dist-git. The change has been also made in f25. It's not good to introduce such changes (i.e. library switch) to stable releases.

Comment 9 olegon.ru 2017-04-19 18:21:14 UTC
Very bad surprise is to delete files by Shift-F6... I expected more stability from well known commander, I love... :(

Is any workaround? Only downgrade?

Comment 10 Ali Akcaagac 2017-04-28 07:36:58 UTC
Contacting FESCo at beginning of next month.

https://bugzilla.redhat.com/show_bug.cgi?id=1436394#c34

Comment 11 Jan Safranek 2017-04-28 13:33:10 UTC
Not only Shift-Fx are broken, ctrl-<arrows>, ctrl-home and ctrl-end are not working in mcedit, which renders it unusable for me.

Comment 12 Fedora Update System 2017-05-05 13:06:53 UTC
mc-4.8.19-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0b205eabf4

Comment 13 Fedora Update System 2017-05-05 13:07:37 UTC
mc-4.8.19-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bf0dcd75c6

Comment 14 Fedora Update System 2017-05-05 13:08:21 UTC
mc-4.8.19-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-70c2e0ec52

Comment 15 Fedora Update System 2017-05-05 20:59:13 UTC
mc-4.8.19-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-70c2e0ec52

Comment 16 Fedora Update System 2017-05-05 21:02:05 UTC
mc-4.8.19-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0b205eabf4

Comment 17 Fedora Update System 2017-05-05 22:39:02 UTC
mc-4.8.19-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bf0dcd75c6

Comment 18 Fedora Update System 2017-05-09 21:24:50 UTC
mc-4.8.19-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2017-05-12 12:04:44 UTC
mc-4.8.19-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2017-05-17 05:56:10 UTC
mc-4.8.19-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.