Bug 1440150 - _ped.PartitionException: Can't add a logical partition to /dev/sda, because there is no extended partition.
Summary: _ped.PartitionException: Can't add a logical partition to /dev/sda, because t...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b0e41a0637b22cd0722b92ec2b4...
: 1440371 1442020 1464382 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-07 12:01 UTC by Martin Kolman
Modified: 2018-11-10 01:46 UTC (History)
12 users (show)

Fixed In Version: python-blivet-2.1.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-20 05:45:49 UTC


Attachments (Terms of Use)
File: anaconda-tb (248.79 KB, text/plain)
2017-04-07 12:01 UTC, Martin Kolman
no flags Details
File: environ (529 bytes, text/plain)
2017-04-07 12:01 UTC, Martin Kolman
no flags Details
File: lsblk_output (1.33 KB, text/plain)
2017-04-07 12:01 UTC, Martin Kolman
no flags Details
File: nmcli_dev_list (1.62 KB, text/plain)
2017-04-07 12:01 UTC, Martin Kolman
no flags Details
File: os_info (447 bytes, text/plain)
2017-04-07 12:01 UTC, Martin Kolman
no flags Details

Description Martin Kolman 2017-04-07 12:01:42 UTC
Description of problem:
Tried to add a couple partitions for the mixed exception test case, had to add logic partitions due to MBR partitioning. I have added and removed a VG before this crash, so that might have influenced things.

Version-Release number of selected component:
anaconda-26.21.1-1

The following was filed automatically by anaconda:
anaconda 26.21.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivetgui/blivetgui.py", line 211, in _reraise_exception
    raise type(exception)(str(exception) + "\n" + traceback)
  File "/usr/lib/python3.6/site-packages/blivetgui/blivetgui.py", line 440, in add_device
    self._reraise_exception(result.exception, result.traceback)
_ped.PartitionException: Can't add a logical partition to /dev/sda, because there is no extended partition.
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/blivetgui/blivet_utils.py", line 1067, in add_device
    blivet.partitioning.do_partitioning(self.storage)
  File "/usr/lib/python3.6/site-packages/blivet/partitioning.py", line 582, in do_partitioning
    allocate_partitions(storage, disks, partitions, free)
  File "/usr/lib/python3.6/site-packages/blivet/partitioning.py", line 961, in allocate_partitions
    _part.req_start_sector, _part.req_end_sector)
  File "/usr/lib/python3.6/site-packages/blivet/partitioning.py", line 446, in add_partition
    constraint=constraint)
  File "/usr/lib64/python3.6/site-packages/parted/decorators.py", line 42, in new
    ret = fn(*args, **kwds)
  File "/usr/lib64/python3.6/site-packages/parted/disk.py", line 245, in addPartition
    constraint.getPedConstraint())
_ped.PartitionException: Can't add a logical partition to /dev/sda, because there is no extended partition.


Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc4.git0.1.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        26

Comment 1 Martin Kolman 2017-04-07 12:01:48 UTC
Created attachment 1269722 [details]
File: anaconda-tb

Comment 2 Martin Kolman 2017-04-07 12:01:49 UTC
Created attachment 1269724 [details]
File: environ

Comment 3 Martin Kolman 2017-04-07 12:01:51 UTC
Created attachment 1269725 [details]
File: lsblk_output

Comment 4 Martin Kolman 2017-04-07 12:01:53 UTC
Created attachment 1269726 [details]
File: nmcli_dev_list

Comment 5 Martin Kolman 2017-04-07 12:01:54 UTC
Created attachment 1269727 [details]
File: os_info

Comment 6 Martin Kolman 2017-04-07 12:45:11 UTC
Similar problem has been detected:

Found a simpler reproducer:
- create an unencrypted /boot primary partition
- create unencrypted / extended partition
- try to create encrypted xfs /home logical partition 
-> Crash! :)

addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc4.git0.1.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         _ped.PartitionException: Can't add a logical partition to /dev/sda, because there is no extended partition.
release:        Cannot get release name.
version:        26

Comment 7 lnie 2017-04-08 07:02:37 UTC
Similar problem has been detected:

Try to create a home partition,but failed 

addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
other involved packages: blivet-gui-2.1.1-1.fc26.noarch
package:        anaconda-core-26.21.1-1.fc26.x86_64
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'children'
release:        Fedora release 26 (Twenty Six)
version:        26

Comment 8 lnie 2017-04-08 08:07:45 UTC
Similar problem has been detected:

create a /home extended partition,and try to create a logical partition on it

addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.0-0.rc3.git0.2.fc26.x86_64
package:        anaconda-26.21.1-1
product:        Fedora
reason:         _ped.PartitionException: Can't add a logical partition to /dev/sda, because there is no extended partition.
release:        Cannot get release name.
version:        26

Comment 9 Vojtech Trefny 2017-04-10 18:31:07 UTC
*** Bug 1440371 has been marked as a duplicate of this bug. ***

Comment 10 Vojtech Trefny 2017-04-10 19:01:47 UTC
"04:17:35,068 DEBUG blivet: removing empty extended partition from sda"

Changing component to blivet, it automatically removes the extended partition after creating, because it is empty.

Comment 11 Vojtech Trefny 2017-04-13 11:11:00 UTC
*** Bug 1442020 has been marked as a duplicate of this bug. ***

Comment 12 Vojtech Trefny 2017-06-23 10:03:32 UTC
*** Bug 1464382 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.