Bug 144019 - proper behaviour if a scsi driver doesn't exist in new kernel?
proper behaviour if a scsi driver doesn't exist in new kernel?
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkinitrd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 14:59 EST by Bill Peck
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2005-01-03 14:59:40 EST
Description of problem:
I'm openening this bugzilla more for a discussion since I don't know
what the correct answer is.

If a newer kernel doesn't have a scsi driver referenced in
/etc/modprobe.conf then /boot/initrd-<kernelver>.img does not get
created, but we continue to make a grub entry for the kernel even
though there is a good chance it won't work without the initrd.

In RHEL 4 it seems to skip any module it doesn't know about and make
the initrd with the modules it does know about.

I'm pretty sure the first situation is a bad one.  I'm not so sure the
 RHEL4 solution is any better though.  Most likely you'll still end up
with a system that won't boot.

Should the proper behaviour be that we don't make a grub entry at all
if any module is missing?  And complain to the user of course.
Comment 2 Arjan van de Ven 2005-01-04 08:55:03 EST
the initrd gets created by mkinitrd; reassigning
Comment 3 Peter Jones 2006-02-03 00:10:07 EST
Complaining to the user won't work -- they don't see the messages in cases like
up2date.

The right answer is that we shouldn't have kernel modules dissapearing, and if
we do we need to update modprobe.conf before new-kernel-package is run in the
%post for the kernel.
Comment 4 RHEL Product and Program Management 2007-10-19 15:10:08 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.