Bug 1440206 - Copy-paste: filename encoding
Summary: Copy-paste: filename encoding
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Victor Toso
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks: 1450061
TreeView+ depends on / blocked
 
Reported: 2017-04-07 14:43 UTC by Radek Duda
Modified: 2017-08-01 15:06 UTC (History)
7 users (show)

Fixed In Version: spice-gtk-0.33-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1450061 (view as bug list)
Environment:
Last Closed: 2017-08-01 15:06:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1849 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2017-08-01 17:49:46 UTC

Description Radek Duda 2017-04-07 14:43:48 UTC
Description of problem:
Filename of copied file from client to guest is not properly encoded

Version-Release number of selected component (if applicable):

Client (rhel7.4):
virt-viewer-5.0-2.el7.x86_64
spice-gtk3-0.33-2.el7.x86_64

Guest1 - rhel7.4
spice-server-0.12.8-1.el7.x86_64
spice-vdagent-0.14.0-14.el7.x86_64

Guest2 - win10
vdagent 1.1.4.1002
RHEV-toolsSetup_4.1_5.iso

How reproducible:
always

Steps to Reproduce:
1. Drag&drop file with non ASCII characters in filename (e.g. 'ěščřžýáíé') from client to guest VM
2.
3.

Actual results:
Rhel Guest1:
File called '\xc4\x9b\xc5\xa1\xc4\x8d\xc5\x99\xc5\xbe\xc3\xbd\xc3\xa1\xc3\xad\xc3\xa9' is pasted

Win Guest2:
Dialog window appears: 'An error caused the following file transfer to fail: ěščřžýáíé'

from spice-debug log:
(remote-viewer:5396): GSpice-DEBUG: spice-widget.c:539 drag_data_received_callback: drag a file
(remote-viewer:5396): GSpice-DEBUG: spice-file-transfer-task.c:675 transfer of file ěščřžýáíé has started
(remote-viewer:5396): GSpice-DEBUG: channel-main.c:3104 Insert a xfer task:1 to task list
(remote-viewer:5396): GSpice-DEBUG: channel-main.c:1845 xfer-task 1 received response 2
(remote-viewer:5396): GSpice-DEBUG: spice-file-transfer-task.c:303 File /home/rduda/Downloads/ěščřžýáíé xfer failed: The spice agent reported an error during the file transfer
(remote-viewer:5396): GSpice-DEBUG: channel-main.c:2885 Transfer failed (0x55cdd9839dd0) Transferring 1 files: 0 succeed, 0 cancelled, 1 failed

(remote-viewer:5396): GSpice-WARNING **: File transfer failed with error: Transferring 1 files: 0 succeed, 0 cancelled, 1 failed
(remote-viewer:5396): Spice-DEBUG: channel-main.c:2904:file_transfer_operation_free: Freeing file-transfer-operation 0x55cdd9839dd0

(remote-viewer:5396): virt-viewer-WARNING **: File transfer task 0x55cdd9850290 failed: The spice agent reported an error during the file transfer


Expected results:
File called 'ěščřžýáíé' is pasted to Guest VM

Comment 2 Victor Toso 2017-04-12 10:36:22 UTC
Fix on mailing list
https://lists.freedesktop.org/archives/spice-devel/2017-April/037127.html

Comment 3 Victor Toso 2017-04-18 12:38:57 UTC
Fixed as 5b9ad92814e3fc488cca8cba41b6af0caa390e1b

Comment 7 errata-xmlrpc 2017-08-01 15:06:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1849


Note You need to log in before you can comment on or make changes to this bug.