Bug 1440215 - Can't connect to Freenode due to EXTERNAL SASL authentication
Summary: Can't connect to Freenode due to EXTERNAL SASL authentication
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pidgin
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-07 15:11 UTC by Christopher Tubbs
Modified: 2020-05-28 14:21 UTC (History)
4 users (show)

Fixed In Version: pidgin-2.10.11-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:37:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
upstream-sasl-fix (1.28 KB, patch)
2017-04-07 19:57 UTC, Christopher Tubbs
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Debian BTS 847674 0 None None None 2017-04-07 15:11:34 UTC
Red Hat Product Errata RHBA-2019:2044 0 None None None 2019-08-06 12:38:31 UTC

Description Christopher Tubbs 2017-04-07 15:11:34 UTC
Description of problem:
Cannot connect to any FreeNode IRC servers using SASL (which now appears to be required on many, if not all, servers). This is because the pidgin client cannot handle the "EXTERNAL" authentication method advertised by the server.

FreeNode is the largest and most popular IRC server network, and being unable to connect to it at all in EL7 is unacceptable.

Version-Release number of selected component (if applicable):
pidgin-2.10.7-26.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Connect to chat.freenode.net on port 7000 with over SSL with SASL authentication

Actual results:
Fails to connect.

Expected results:
Should connect.

Additional info:
This bug was reported against Debian at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=847674 and upstream at https://pidgin.im/pipermail/support/2016-September/029627.html and fixed in upstream with https://bitbucket.org/pidgin/main/commits/610656636af6d1d6fdd6723d5ef311c903b6a804?at=default

Comment 2 Christopher Tubbs 2017-04-07 19:54:18 UTC
I applied the upstream patch to the source RPM I got from CentOS 7 and rebuilt from source. I then installed the updated version of pidgin and libpurple to test, and can confirm that it fixes this bug.

Comment 3 Christopher Tubbs 2017-04-07 19:57:30 UTC
Created attachment 1269909 [details]
upstream-sasl-fix

Uploaded upstream patch from https://bitbucket.org/pidgin/main/commits/610656636af6d1d6fdd6723d5ef311c903b6a804/raw

Comment 4 Christopher Tubbs 2017-09-29 20:20:48 UTC
Still broken in 7.4 with pidgin-2.10.11-5.el7
This is a trivial patch to apply, which is fixed in upstream as of 2.12.0
Please fix.

Comment 5 Debarshi Ray 2019-03-18 17:10:58 UTC
Here's a scratch build:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=20652569

Comment 6 Debarshi Ray 2019-03-19 13:41:26 UTC
Built pidgin-2.10.11-8.el7:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=20662915

Comment 9 Debarshi Ray 2019-03-19 14:52:20 UTC
This ought to be part of https://errata.devel.redhat.com/advisory/38320 instead.

Comment 12 Petr Schindler 2019-05-07 08:15:32 UTC
Works with version pidgin-2.10.11-8.el7.x86_64.

I'm able to connect to chat.freenode.net:7000 with SSL and SASL authentication. Sanity tests passed as well.

Comment 14 errata-xmlrpc 2019-08-06 12:37:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2044


Note You need to log in before you can comment on or make changes to this bug.