Bug 144046 - Openoffice.org does not cache changes to a temporary file for recovery after a crash
Openoffice.org does not cache changes to a temporary file for recovery after ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 21:10 EST by Xander D Harkness
Modified: 2016-06-07 18:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 19:39:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2005-01-03 21:10:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
If I receive an openoffice document via email, open from evolution and
subsequently suffer an openoffice.org crash (which seems to happen
fairly frequently), I have no record of any changes.  If
Openoffice.org were to dump changes to a known temporary file it could
offer to recover when restarted.

The last crash was caused by opening the new fangled gnome file dialog
box to save to a known location, having made appropriate changes.  I
am unable to replicate the crash and this is a too regular occurrence.

I am unable to set openoffice.org to automatically save a file every
minute, for if I want to start with a document as a template, start
making changes and forget to save to a new file, I am too late to
preserve the original document.

I know that this seems really obvious that unsaved changes will not be
present; however openoffice.org is not the most stable application and
even vim, which is incredibly stable (and small) has this ability.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
1. Open a document for editing and make changes until a crash occurs
2. Open document again and all changes are lost.
3.
    

Actual Results:  All new data written to the application is lost.

Expected Results:  Openoffice.org should be able to recover gracefully
from a crash and recover data it has lost.

Additional info:
Comment 1 Xander D Harkness 2005-01-05 19:39:56 EST
This facility is provided in Openoffice.org release 2

Note You need to log in before you can comment on or make changes to this bug.