Bug 144055 - removal of shmem_file_setup export breaks modules
Summary: removal of shmem_file_setup export breaks modules
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-04 06:19 UTC by Brett Pemberton
Modified: 2015-01-04 22:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 06:28:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brett Pemberton 2005-01-04 06:19:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
http://linux.bkbits.net:8080/linux-2.5/diffs/mm/shmem.c@1.170?nav=index.html|src/|src/mm|hist/mm/shmem.c

this change breaks compilation of external modules which use this
symbol, myrinet drivers for one.  Given the benefit of this patch is a
few bytes saved, compared to much hassle, reverting this patch would
be a definite improvement.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.724_FC3smp

How reproducible:
Always

Steps to Reproduce:
1. compile an external module that uses shmem_file_setup
2. try to insmod
3.
    

Actual Results:  module won't insert, due to missing exported symbol

Expected Results:  module inserts fine

Additional info:

Comment 1 Dave Jones 2005-01-04 06:28:08 UTC
this went away in 2.6.10. If we re-add exports that went away
upstream, we tag them with _GPL. This means your part binary module
would still not be able to work.  This is something the myrinet folks
are going to have to work out differently.



Note You need to log in before you can comment on or make changes to this bug.