Bug 144066 - kernel panic starting software linear raid array
kernel panic starting software linear raid array
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-01-04 06:09 EST by Michal Szymanski
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Szymanski 2005-01-04 06:09:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
After upgrading kernel from 2.6.7-1.494.2.2 to 2.6.9-1.6, software
linear raid array made on hdc2+hdd1 hangs the system when starting.
Kernel panics. With 2.6.7-1.494.2.2 it works fine. I tried to change
the partition type to 0xFD to let the kernel start the array but it
does not work (neither in 2.6.7 nor in 2.6.9), reporting:

md: Autodetecting RAID arrays.
md: autorun ...
md: considering hdd1 ...
md:  adding hdd1 ...
md:  adding hdc2 ...
md: created md0
md: bind<hdc2>
md: bind<hdd1>
md: running: <hdd1><hdc2>
md: personality 1 is not loaded!
md :do_md_run() returned -22
md: md0 stopped.
md: unbind<hdd1>
md: export_rdev(hdd1)
md: unbind<hdc2>
md: export_rdev(hdc2)
md: ... autorun DONE.

Only user-space "raidstart" (raidtools-1.00.3-8) works in 2.6.7
(panics in 2.6.9). The machine is a dual Athlon MP 2000+, MSI K7D
Master motherboard, 3GB RAM, three IDE HDDs (40GB system disk hda,
2x200GB for the data raid array hdc+hdd).

/etc/raidtab contains:
raiddev /dev/md0
        raid-level              linear
        nr-raid-disks           2
        persistent-superblock   1
        chunk-size              32
        device                  /dev/hdc2
        raid-disk               0
        device                  /dev/hdd1
        raid-disk               1

I tried both smp and up 2.6.9 kernel, same result.

regards, Michal.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.choose 2.6.9 kernel in GRUB

Actual Results:  kernel panics when starting the raid array

Expected Results:  system should boot up cleanly :)

Additional info:
Comment 1 Dave Jones 2005-04-16 01:04:20 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.