Bug 144068 - latest kernel breaks netdump
latest kernel breaks netdump
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 06:24 EST by Phil Anderson
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 16:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Anderson 2005-01-04 06:24:12 EST
Description of problem:
The latest kernel breaks netdump, as it is is misisng netdump.ko.

Version-Release number of selected component (if applicable):
2.6.9-1.724_FC3 

How reproducible:
Always

Steps to Reproduce:
1. Update to 2.6.9-1.724_FC3 
2. service netdump start
  
Actual results:
initializing netdump FATAL: Module netdump not found.
initializing netconsole FATAL: Error inserting netconsole
(/lib/modules/2.6.9-1.724_FC3smp/kernel/drivers/net/netconsole.ko):
Invalid argument
Comment 1 Barry K. Nathan 2005-01-05 10:51:54 EST
The netdump module also seems to be missing from 2.6.10-1.727_FC3
Comment 2 Phil Anderson 2005-01-11 15:39:59 EST
Still broken in 2.6.10-1.737_FC3
Comment 3 Sitsofe Wheeler 2005-01-12 05:28:22 EST
I remember reading in the kernel changelogs that it had been taken out in
preperation of being replaced with a new kexec system...

Hmm just found this:
http://diary.codemonkey.org.uk/index.php?month=12&year=2004#20041216 and this
http://www.redhat.com/archives/fedora-devel-list/2004-December/msg00637.html
Comment 4 Phil Anderson 2005-01-12 05:56:31 EST
Surely this is a mistake to remove it from the FC3 kernel though
Comment 5 Barry K. Nathan 2005-01-12 08:41:44 EST
Given that they dropped 4g4g (and seeing how that affected some people
severely), who knows if it was intentional or a mistake.
Comment 6 Dave Jones 2005-01-12 12:47:35 EST
it was intentional, as it rejected once I rebased and various other
patches got dropped. rediffing it and getting it back into fc2/fc3 is
on my todo list, though there are higher priority things right now.
Comment 7 Dave Jones 2005-01-18 18:21:15 EST
fixed in cvs, will be in the next build.

Note You need to log in before you can comment on or make changes to this bug.