Bug 144083 - latex-mode-hook is not run
latex-mode-hook is not run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 08:33 EST by Martin Biely
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 21.3-27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 04:14:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
emacs-21.3-latex-mode-hook-144083.patch (523 bytes, patch)
2005-03-15 07:02 EST, Jens Petersen
no flags Details | Diff

  None (edit)
Description Martin Biely 2005-01-04 08:33:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041129 Firefox/1.0

Description of problem:
Documentation string of latex-mode says: 
  "[...] Entering Latex mode runs the hook `text-mode-hook', then
   `tex-mode-hook', and finally `latex-mode-hook'.  When the special
   subshell is initiated, `tex-shell-hook' is run."
latex-mode-hook is never run however. [not even defvar'd]
Also the text-mode-hook is not run.

Line 822 of tex-mode.el only says: 
   (run-hooks 'tex-mode-hook))
whereas the correct (IMHO) behaviour would be 
[as done by xemacs' version of tex-mode.el line 354]
   (run-hooks 'text-mode-hook 'tex-mode-hook 'latex-mode-hook))




Version-Release number of selected component (if applicable):
emacs-common-21.3-12, emacs-el-21.3-12

How reproducible:
Always

Steps to Reproduce:
start latex-mode
    

Actual Results:  latex-mode-hook is not run (is never defined)

Expected Results:  latex-mode-hook should be run (according to
documentation)

Additional info:
assuming all platforms since bug is caused by emacs-lisp code.
Comment 1 Jens Petersen 2005-02-24 11:00:13 EST
This seems to have been fixed by now in cvs emacs.

Adding a patch to next build to fix this.
Comment 2 Jens Petersen 2005-02-25 08:31:09 EST
Should be fixed in 21.3-24.  Please confirm. 
Comment 3 Martin Biely 2005-03-14 15:17:43 EST
It is not fixed with:
emacs-21.3-25
emacs-common-21.3-25
emacs-el-21.3-25
emacs-leim-21.3-25
emacs-nox-21.3-25
packages from
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

I didn't find the -24 version and did not have time to check the last few weeks.
has someone undone the patch ?
Comment 4 Jens Petersen 2005-03-15 07:02:50 EST
Created attachment 112014 [details]
emacs-21.3-latex-mode-hook-144083.patch





Right, the above patch is currently only in FC/devel (rawhide).

I feel this change is too small to warrant a whole FC3 update
of Emacs in itself.  But please either install the build
in rawhide or try the above patch on your install.
Comment 5 Martin Biely 2005-03-15 18:40:14 EST
OK. it works with both (1) the patch and (2) the emacs version from your
apt-repository (21.3.50-0.20041210). I couldn't resolve FC/devel (rawhide) :-(

thanks
Comment 6 Jens Petersen 2005-04-06 12:20:47 EDT
Sorry, seems the patch wasn't actually being applied in rawhide yet.
It should really be there from 21.3-27.

fc devel (formerly rawhide) means the current Fedora Core Development Tree:
see eg /etc/yum.repos.d/fedora-devel.repo or your local fedora mirror.

Note You need to log in before you can comment on or make changes to this bug.