Bug 1440908 - Frequent failure at Subnet deletion with 3 controller
Summary: Frequent failure at Subnet deletion with 3 controller
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Assaf Muller
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On: 1440897
Blocks: 1440901
TreeView+ depends on / blocked
 
Reported: 2017-04-10 17:54 UTC by Ihar Hrachyshka
Modified: 2017-06-20 12:57 UTC (History)
8 users (show)

Fixed In Version: openstack-neutron-7.2.0-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1440897
Environment:
Last Closed: 2017-06-20 12:57:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1680912 None None None 2017-04-10 17:54:15 UTC
Red Hat Product Errata RHBA-2017:1540 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2017-06-20 16:55:20 UTC

Description Ihar Hrachyshka 2017-04-10 17:54:15 UTC
+++ This bug was initially created as a clone of Bug #1440897 +++

Description of problem:
4 thread tempest runs, frequently fail with subnet deletion.
 

The log contains:

2017-04-07 02:01:40,246 24529 WARNING  [urllib3.connectionpool] Retrying (Retry(total=9, connect=None, read=None, redirect=5)) after connection broken by 'ReadTimeoutError("HTTPConnectionPool(host='10.0.0.110', port=9696): Read timed out. (read timeout=60)",)': /v2.0/subnets/9197a378-4a60-4e60-a0e0-1df71e26a35e



Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/subnets_client.py", line 52, in delete_subnet
    return self.delete_resource(uri)
  File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/base.py", line 41, in delete_resource
    resp, body = self.delete(req_uri)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 307, in delete
    return self.request('DELETE', url, extra_headers, headers, body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 665, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 762, in _error_checker
    raise exceptions.NotFound(resp_body, resp=resp)
tempest.lib.exceptions.NotFound: Object not found
Details: {u'message': u'Subnet 9197a378-4a60-4e60-a0e0-1df71e26a35e could not be found.', u'type': u'SubnetNotFound', u'detail': u''}
And at the cleanup phase you also see:


Version-Release number of selected component (if applicable):
python-neutron-lbaas-10.0.0-5.el7ost.noarch
python-neutronclient-6.1.0-1.el7ost.noarch
puppet-neutron-10.3.0-2.el7ost.noarch
openstack-neutron-common-10.0.0-13.el7ost.noarch
openstack-neutron-lbaas-10.0.0-5.el7ost.noarch
openstack-neutron-openvswitch-10.0.0-13.el7ost.noarch
python-neutron-10.0.0-13.el7ost.noarch
openstack-neutron-10.0.0-13.el7ost.noarch
openstack-neutron-metering-agent-10.0.0-13.el7ost.noarch
python-neutron-lib-1.1.0-1.el7ost.noarch
openstack-neutron-sriov-nic-agent-10.0.0-13.el7ost.noarch
openstack-neutron-ml2-10.0.0-13.el7ost.noarch


How reproducible:
25% chance with  ostestr -r PortsIpV6TestJSON

--- Additional comment from Ihar Hrachyshka on 2017-04-10 13:34:50 EDT ---

This is a known regression in Ocata and earlier tracked in upstream as: https://bugs.launchpad.net/neutron/+bug/1680912

Comment 1 Red Hat Bugzilla Rules Engine 2017-04-10 17:54:28 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 6 errata-xmlrpc 2017-06-20 12:57:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1540


Note You need to log in before you can comment on or make changes to this bug.