Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 144094 - Python distutils reports incorrect lib location
Python distutils reports incorrect lib location
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
RHEL3U7NAK
:
: 180023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 10:07 EST by Jason McCormick
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0468
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:46:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0468 normal SHIPPED_LIVE python bug fix update 2007-06-07 16:01:08 EDT

  None (edit)
Description Jason McCormick 2005-01-04 10:07:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041109 Firefox/1.0

Description of problem:
Python's distutils package reports the incorrect path for the location
of the usable python packages.  On x86_64 the location of these files
is /usr/lib64/python2.2 however Python itself reports that its files
should be in /usr/lib/python2.2.

Note: I am not a Python developer so I may be using terms incorrectly.
 I ran into the problem while trying to build PostgreSQL 7.4.6.

Version-Release number of selected component (if applicable):
python-2.2.3-6

How reproducible:
Always

Steps to Reproduce:
$ python
Python 2.2.3 (#1, Oct 26 2004, 17:14:26) 
[GCC 3.2.3 20030502 (Red Hat Linux 3.2.3-47)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from distutils import sysconfig
>>> print sysconfig.get_config_vars('LIBDEST')


Actual Results:  ['/usr/lib/python2.2']


Expected Results:  ['/usr/lib64/python2.2']

Additional info:

  The compilation of PostgreSQL fails because it cannot find the
proper location for the files it needs to build the python
interface/bindings.
Comment 10 Jeremy Katz 2006-12-20 18:24:17 EST
*** Bug 180023 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2006-12-21 18:18:28 EST
Committed a fix and building as python-2.2.3-6.6
Comment 19 Red Hat Bugzilla 2007-06-11 14:46:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0468.html

Note You need to log in before you can comment on or make changes to this bug.