Bug 144100 - Systems do not install after a hard drive warning on second drive.
Systems do not install after a hard drive warning on second drive.
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 10:48 EST by Tim Skirvin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:10:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Our ks.cfg file (3.45 KB, text/plain)
2005-01-04 10:50 EST, Tim Skirvin
no flags Details
scratch disk creation script (3.28 KB, text/plain)
2005-01-04 10:52 EST, Tim Skirvin
no flags Details
Requested copy of the error message (1.18 KB, text/plain)
2005-04-15 10:27 EDT, Tim Skirvin
no flags Details

  None (edit)
Description Tim Skirvin 2005-01-04 10:48:52 EST
Description of problem:

If there's a second hard drive installed in our desktop systems as we
install them, then we cannot install RH Desktop.  We must disconnect
the drive to continue.  This appears to be a bug in the python
installation scripts.

Version-Release number of selected component (if applicable):

RH Academic Desktop 3 Release 3

How reproducible:

Every time.

Steps to Reproduce:
1.  Install two hard drives: one SCSI (primary), one IDE (secondary).
 This second HD is not perfectly formatted.  (I've attached the
scripts we used for format these drives.)
2.  Start an install off a CD with a specific ks.cfg (I've attached it).
3.  The system gripes about "disk improperly formatted".  We ignore
this warning, as it is just a warning on our 32-bit systems.
4.  We get a screen of python errors indicating that up2date has failed.
  
Actual results:

A large screen of python errors, which (since I can't cut-and-paste) I
won't transcribe here.


Expected results:

Should let us continue installing after the error, as our 32-bit
systems do.  If we remove the hard drive and continue the install


Additional info:

I'll attach a copy of our ks.cfg and our scratch drives later.
Comment 1 Tim Skirvin 2005-01-04 10:50:51 EST
Created attachment 109328 [details]
Our ks.cfg file

This is installed on the CD media, which starts an automatic install.  Used for
single-step system installation.
Comment 2 Tim Skirvin 2005-01-04 10:52:21 EST
Created attachment 109329 [details]
scratch disk creation script

We use this script to create the scratch drives.  It's not bug-free, and
usually causes a warning on future RH installs; it's probably just an
off-by-one error on drive creation.  Regardless, it shouldn't make the install
crash entirely.
Comment 3 Jeremy Katz 2005-01-04 15:56:14 EST
Please provide the exception you receive.  You should be able to save it to a
floppy and provide it.  Without it, it's pretty much impossible for me to say
what's going on.
Comment 4 Tim Skirvin 2005-01-04 16:00:13 EST
I don't have floppy drives on these systems.  
Comment 5 Jeremy Katz 2005-02-01 17:14:38 EST
If you switch to tty2 when the exception occurs, you should be able to scp off
the exception (it's stored in /tmp/anacdump.txt)
Comment 6 Tim Skirvin 2005-04-15 10:27:28 EDT
Created attachment 113223 [details]
Requested copy of the error message

Sorry this took so long; we didn't have spare machines to attempt to reinstall.
 The message was transcribed by hand.
Comment 7 Jeremy Katz 2005-09-21 15:10:16 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further information, feel free to
add to the report and reopen.

Note You need to log in before you can comment on or make changes to this bug.