Bug 144104 - System hangs for several seconds while loading aic79xx module
System hangs for several seconds while loading aic79xx module
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 10:59 EST by Tim Skirvin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:09:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages describing boot process (25.00 KB, text/plain)
2005-01-31 10:47 EST, Tim Skirvin
no flags Details

  None (edit)
Description Tim Skirvin 2005-01-04 10:59:16 EST
Description of problem:

Our systems hang for 5-10 seconds on boot, while trying to load the
aic79xx module.

Version-Release number of selected component (if applicable):

RH Academic Desktop 3 R4


How reproducible:

Every boot on our Sun W2100z workstations.

Steps to Reproduce:
1.  Start boot
2.  Watch messages until it gets to "Loading aic79xx module." message.
3.  Wait.
  
Actual results:

5-10 second wait.

Expected results:

Minimal wait at best.


Additional info:
Comment 1 Tom Coughlan 2005-01-04 17:14:05 EST
The default selection timeout on SCSI is .25 sec. Times 16 targets, gives 4
seconds, so it is going to take a while, especially on an unpopulated SCSI bus.
 5-6 seconds seems normal.

Please add this to modules.conf:

options aic79xx aic79xx=verbose,seltime:3

Re-make the initrd, and reboot.  This reduces the selection timeout to 32ms.
This should be safe for modern SCSI devices. See it this makes a difference, and
post the results of /var/log/messages.  If you can, point out where the long the
delay occurs in the log.

Tom
Comment 2 Tim Skirvin 2005-01-04 17:55:38 EST
This actually increased the load time to ~30 seconds.  There were no messages to
/var/log/messages; this is all being done before it's actually mounted any file
systems.  

*checks*  It wasn't much different without that line.  (~27 seconds.)
Comment 3 Tim Skirvin 2005-01-28 12:07:41 EST
So, is anything being done on this?
Comment 4 Tom Coughlan 2005-01-31 10:05:44 EST
When you get to "Loading aic79xx module." the system will log a bunch of
messages related to module/adapter initialization, and SCSI bus scanning. These
will be in dmesg and /var/log/messages after the system finishes booting.

Please add this to modules.conf:

options aic79xx aic79xx=verbose

Re-make the initrd, and reboot. Then post /var/log/messages showing the boot
messages. 

Also check the log for any other errors on this adapter during normanl use. 
Comment 5 Tim Skirvin 2005-01-31 10:47:57 EST
Created attachment 110441 [details]
/var/log/messages describing boot process

As requested.  I don't see much useful information on there, though.  There are
no other error messages regarding the aic79xx.
Comment 6 Tom Coughlan 2005-01-31 14:04:47 EST
This is a stab, but would you try booting with "noapic" on the kernel command
line? See it this makes a difference.
Comment 7 Erik Volkman 2005-02-01 15:44:13 EST
Adding noapic to the kernel boot parameters worsened the problem. The
computers did do anything after the Loading aic79xx module for at
least 5+ minutes at which time they were given a hard reboot. In
addition we got the following error message for probably every IRQ.

ERROR: Unable to locate IOAPIC for IRQ ## \n
Comment 8 Tom Coughlan 2005-09-19 10:59:45 EDT
Going back through old bug reports.... I overlooked this because it was still in
"needinfo". Is this still an issue for you?

As I said in comment #1, it is not unusual for the loading of a SCSI driver to
take 4-5 seconds per SCSI bus. The time is required to scan the bus. I see this
on a system here:

# time modprobe aic79xx

real    0m26.795s
user    0m0.010s
sys     0m0.290s

The delay occurs _after_ the following is printed on the console:

PCI: Enabling device 00:03.0 (0156 -> 0157)
PCI: Enabling device 00:03.1 (0156 -> 0157)
        <Adaptec 39320 Ultra320 SCSI adapter>
        aic7902: Ultra320 Wide Channel A, SCSI Id=7, PCI 33 or 66Mhz, 512 SCBs

        <Adaptec 39320 Ultra320 SCSI adapter>
        aic7902: Ultra320 Wide Channel B, SCSI Id=7, PCI 33 or 66Mhz, 512 SCBs

while the busses are scanned. Does this match when you see the delay? 

There is not much that can be done other than to try some module parameters to
limit the number of target IDs or the timeout during the scan. Let me know if
you need assistance with this.  Otherwise I will close this BZ. 
Comment 10 RHEL Product and Program Management 2007-10-19 15:09:59 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.