Bug 1441066
| Summary: | [RHOSP10] An instance failed to reboot even if only one path of the multipath was failed. | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | weiguo fan <fan-wxa> |
| Component: | python-os-brick | Assignee: | Gorka Eguileor <geguileo> |
| Status: | CLOSED ERRATA | QA Contact: | Avi Avraham <aavraham> |
| Severity: | high | Docs Contact: | |
| Priority: | high | ||
| Version: | 10.0 (Newton) | CC: | acanan, berrange, cchen, dasmith, eglynn, eharney, geguileo, hfukumot, kchamart, knoha, lhh, lyarwood, mas-hatada, mwitt, panbalag, pgrist, redhat-bz, rhel-osp-bz, sbauza, sferdjao, sgordon, sputhenp, srevivo, vaggarwa, vromanso, ykawada |
| Target Milestone: | z5 | Keywords: | Triaged, ZStream |
| Target Release: | 10.0 (Newton) | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | python-os-brick-1.6.1-5.el7ost | Doc Type: | Bug Fix |
| Doc Text: |
Complete refactoring of the iSCSI connection mechanism for improved reliability.
For optimum results, use with openstack-cinder version 9.1.4-7 or higher and iscsi-initiator-utils version 6.2.0.874-2 or higher.
|
Story Points: | --- |
| Clone Of: | 1436116 | Environment: | |
| Last Closed: | 2017-09-28 16:35:22 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1422941 | ||
| Bug Blocks: | 1389374, 1428662, 1442637, 1501950, 1502013 | ||
|
Description
weiguo fan
2017-04-11 07:01:34 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release. This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release. *** Bug 1482846 has been marked as a duplicate of this bug. *** verified installed RPM: [root@compute-1 ~]# rpm -qa |grep os-brick python-os-brick-1.6.1-6.el7ost.noarch 1) create instance 2) attached volume 3) block in compute node using iptables drop command one ISCSI path 4) run the following command : openstack server reboot --hard inst 5) test instance availability after reboot and volume attachment Due to Kaminario our ISCSI backend storage limitations we can not rerun this scenario blocking the other ISCSI interface Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2017:2825 *** Bug 1416641 has been marked as a duplicate of this bug. *** |