Bug 144130 - ipw2200 v0.13 is horribly broken
ipw2200 v0.13 is horribly broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 13:54 EST by Dax Kelson
Modified: 2015-01-04 17:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 19:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2005-01-04 13:54:31 EST
Description of problem:

I just noticed the errata FC3 kernel kernel-2.6.9-1.724_FC3 now
includes the Centrino wireless drivers (yah!).

I found out that the ipw2200 driver was v0.13. :(

The 0.13 driver has numerous kernel panic bugs because of bad locking
that usually only show up at G data rates.

Additionally 0.13 (and higher, until v0.19) has a major bug that
doesn't allow association to an access point if the access point is
serving multiple wireless networks (common in the enterprise, not
common at home).

See bug: http://www.bughost.org/bugzilla/show_bug.cgi?id=207

Basically, please upgrade to the v0.19 ipw2200 driver as it has proven
stable under heavy load and will associate to APs with multiple networks.

At our office we have 6 Linux instructors who all have laptops with
the ipw2200 card, so we have a lot of experience with this and it
makes a big difference for us.
Comment 1 Nicolai Langfeldt 2005-02-26 12:02:42 EST
It's still horribly broken in the kernel-2.6.10-1.741_FC3 kernel package. 
Compiled 0.19 from source and as ever it worked at once.

Nicolai
Comment 2 Dax Kelson 2005-05-03 15:42:42 EDT
I noticed that kernel-2.6.11-1.14_FC3 now ships v1.0. Great!

This can probably be closed now, but it should be noted that there is newer
version of this driver (1.0.3 as of this writing) and they solve a
hang-on-big-file-xfer problem for me.
Comment 3 Dave Jones 2005-05-09 19:53:56 EDT
I'll rebase the FC4 kernel to it sometime, and backport it to FC3 later.

Note You need to log in before you can comment on or make changes to this bug.