Bug 1441499 - ipa cert-show does not raise error if no file name specified
Summary: ipa cert-show does not raise error if no file name specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-12 06:23 UTC by Abhijeet Kasurde
Modified: 2017-08-01 09:48 UTC (History)
5 users (show)

Fixed In Version: ipa-4.5.0-14.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:48:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
console.log (3.04 KB, text/plain)
2017-06-06 09:50 UTC, Abhijeet Kasurde
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Abhijeet Kasurde 2017-04-12 06:23:26 UTC
Description of problem:
When user does not specify file name in `--certificate-out`, command does not raise error "Filename is empty"

[root@vm-idm-010 ~]# ipa cert-show 1 --certificate-out=
  Issuing CA: ipa
  Certificate: <snipped>/eoZcrUgTVtUk7qapoBfFf/iUE=
  Subject: CN=Certificate Authority,O=TESTRELM.TEST
  Issuer: CN=Certificate Authority,O=TESTRELM.TEST
  Not Before: Wed Apr 12 05:05:02 2017 UTC
  Not After: Sun Apr 12 05:05:02 2037 UTC
  Serial number: 1
  Serial number (hex): 0x1
  Revoked: False

Version-Release number of selected component (if applicable):
ipa-server-4.5.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ipa cert-show 1 --certificate-out=

Actual results:
Certificate is shown at stdout

Expected results:
Command should complain as "Filename is empty"

Comment 3 Petr Vobornik 2017-04-20 16:25:52 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6885

Comment 6 Abhijeet Kasurde 2017-06-06 09:39:03 UTC
Verified using IPA version :: ipa-server-4.5.0-14.el7.x86_64

Marking BZ as verified. See attachment for console log.

Comment 7 Abhijeet Kasurde 2017-06-06 09:50:03 UTC
Created attachment 1285320 [details]
console.log

Comment 8 errata-xmlrpc 2017-08-01 09:48:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.