Bug 1441512 - Guest fails boot up with ivshmem-plain and virtio-blk-pci device
Summary: Guest fails boot up with ivshmem-plain and virtio-blk-pci device
Keywords:
Status: CLOSED DUPLICATE of bug 1393322
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios
Version: 7.4
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Marcel Apfelbaum
QA Contact: FuXiangChun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-12 07:08 UTC by Sitong Liu
Modified: 2017-07-11 06:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-02 01:50:20 UTC


Attachments (Terms of Use)
guest hang (6.26 KB, image/png)
2017-04-12 07:11 UTC, Sitong Liu
no flags Details

Description Sitong Liu 2017-04-12 07:08:43 UTC
Description of problem:
Boot RHEL7.4 guest with ivshmem-plain and virtio-blk-pci and the latest seabios-1.10.2-2.el7.x86_64. Guest kernel can not be loaded. I added a guest screen to attachment. If boot guest with ide-driver+seabios-1.10.2-2.el7.x86_64. guest works well.

QE also tested previous seabios version(seabios-1.9.1-5.el7.x86_64). Guest work well. According to bug 1373154, This issue has been fixed with seabios-1.9.1-5.el7.x86_64 before. So it is a regression bug. 

Version-Release number of selected component (if applicable):
seabios-1.10.2-2.el7.x86_64
qemu-kvm-rhev-2.9.0-0.el7.mrezanin201703210848.x86_64
3.10.0-648.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.
/usr/libexec/qemu-kvm -name seabios-test -enable-kvm -m 4G -cpu Opteron_G5  -smp 4,cores=4,threads=1,sockets=1,maxcpus=4 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/126NICW10S64SOB,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cdn,menu=on -drive file=/home/rhel7.4.qcow2,if=none,id=drive-virtio0-0-0,format=qcow2,serial=mike_cao,cache=none -device virtio-blk-pci,drive=drive-virtio0-0-0,id=virtio0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=a0:d3:c1:fb:dd:d2,bus=pci.0,addr=0x4 -vnc :2  -monitor stdio -vga qxl -serial unix:/tmp/console,server,nowait \ 

-object memory-backend-file,id=mem,size=4096M,mem-path=/dev/hugepages,share=on -device ivshmem-plain,memdev=mem \
2.
3.

Actual results:
Guest fail

Expected results:
works

Additional info:

Comment 3 Sitong Liu 2017-04-12 07:11:25 UTC
Created attachment 1271060 [details]
guest hang

Comment 4 Marcel Apfelbaum 2017-04-20 19:49:01 UTC
I think this is a duplicate of:
    https://bugzilla.redhat.com/show_bug.cgi?id=1393322

Please close it if I am right.
Thanks,
Marcel

Comment 5 Sitong Liu 2017-05-02 01:50:20 UTC

*** This bug has been marked as a duplicate of bug 1393322 ***


Note You need to log in before you can comment on or make changes to this bug.