Bug 1441620 - All angular-based views are broken
Summary: All angular-based views are broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-12 11:05 UTC by Radomir Dopieralski
Modified: 2017-05-17 20:20 UTC (History)
10 users (show)

Fixed In Version: python-XStatic-Angular-Bootstrap-2.2.0.0-1.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-05-17 20:20:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Radomir Dopieralski 2017-04-12 11:05:49 UTC
Description of problem:

All AngularJS-based views in Horizon fail with a javascript error:

Uncaught Error: [$injector:unpr] Unknown provider: $uibModalProvider <- $uibModal <- horizon.framework.widgets.modal.wizard-modal.service <- horizon.app.core.images.actions.edit.service
http://errors.angularjs.org/1.5.8/$injector/unpr?p0=%24uibModalProvider%20%…wizard-modal.service%20%3C-%20horizon.app.core.images.actions.edit.service
    at 4ae1ca88d058.js:699
    at 4ae1ca88d058.js:913
    at Object.getService [as get] (4ae1ca88d058.js:929)
    at 4ae1ca88d058.js:913
    at getService (4ae1ca88d058.js:929)
    at injectionArgs (4ae1ca88d058.js:932)
    at Object.invoke (4ae1ca88d058.js:937)
    at Object.enforcedReturnValue [as $get] (4ae1ca88d058.js:917)
    at Object.invoke (4ae1ca88d058.js:938)
    at 4ae1ca88d058.js:913



Version-Release number of selected component (if applicable):

python-XStatic-Angular-Bootstrap-0.11.0.2-1.el7ost.noarch


How reproducible:

100%

Steps to Reproduce:
1. Go to project→instances and click on the "launch instance" button
2. Try going to project→images
3. Look at the browser's error console

Actual results:

The button does nothing, the images view displays empty. There are errors in the console.

Expected results:

The "launch instance" dialog should appear, and the "images" view should display. There should be no errors in the console.

Additional info:

The problem is due to python-XStatic-Angular-Bootstrap being too old. This commit bumps the requirements upstream: https://github.com/openstack/horizon/commit/ed772a9097fc010560408c7aee07159f657ea636

We need to be shipping XStatic-Angular-Bootstrap>=2.2.0.0

Comment 1 Red Hat Bugzilla Rules Engine 2017-04-12 11:07:49 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 4 Radomir Dopieralski 2017-04-12 12:45:45 UTC
A workaround is to install the newer packages from RDO, for instance, from: https://cbs.centos.org/koji/buildinfo?buildID=15447

(Both python-XStatic-Angular-Bootstrap and xstatic-angular-bootstrap-common need to be updated.)

Comment 7 errata-xmlrpc 2017-05-17 20:20:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.