Bug 1441698 - Missing rpm dependency to urw-fonts
Summary: Missing rpm dependency to urw-fonts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-12 13:51 UTC by Jiri Hnidek
Modified: 2017-08-01 19:22 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.19.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Subscription with corrupted GUI (missgin fonts) (12.43 KB, image/png)
2017-04-12 13:51 UTC, Jiri Hnidek
no flags Details
GUI with fonts after installing xauth and sub-man-gui on a rhel 7 server with minimum installation (157.12 KB, image/png)
2017-05-04 11:24 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1586 None None None 2017-04-13 12:46:43 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Jiri Hnidek 2017-04-12 13:51:32 UTC
Created attachment 1271152 [details]
Subscription with corrupted GUI (missgin fonts)

Description of problem:
Package subscription-manager-gui miss RPM dependency at urw-fonts and it is displayed without fonts, when it is started remotely at server with minimal installation.

Version-Release number of selected component (if applicable):
[root@rhel01 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.17.15-1.el7
python-rhsm: 1.17.9-1.el7

How reproducible:
always

Steps to Reproduce:
1. Install RHEL server with minimal installation (no desktop)
2. # yum install -y xauth subscription-manager-gui
3. Login at this server using: ssh -X rhel.minimal.server.com
4. Start Subscription Manager with GUI: # subscription-manager-gui

Actual results:
Subscription Manager without any fonts and not too useful (screenshot attached). It also prints following message at console:

[root@rhel01 ~]# subscription-manager-gui

** (subscription-manager-gui:15299): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gZzpaVu46K: Connection refused
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(subscription-manager-gui:15299): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'

(subscription-manager-gui:15299): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'

Expected results:
Subscription Manager with normal GUI.

Additional info:
You can fix this problem installing following rpm package with fonts: yum -y install urw-fonts

Comment 5 Shwetha Kallesh 2017-05-04 11:24:33 UTC
Created attachment 1276271 [details]
GUI with fonts after installing xauth and sub-man-gui on a rhel 7 server with minimum installation

[root@dhcp71-2 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

Comment 6 errata-xmlrpc 2017-08-01 19:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.