Bug 1441750 - undercloud deployment fails b/c it tries to install openstack-kolla
Summary: undercloud deployment fails b/c it tries to install openstack-kolla
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Martin André
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1576410
TreeView+ depends on / blocked
 
Reported: 2017-04-12 15:35 UTC by Thierry Vignaud
Modified: 2018-08-03 18:30 UTC (History)
8 users (show)

Fixed In Version: puppet-tripleo-7.1.1-0.20170623015402.2625756.el7ost instack-undercloud-7.1.1-0.20170623182135.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1576410 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:23:38 UTC
Target Upstream Version:
tvignaud: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 456290 None None None 2017-05-22 16:12:50 UTC
OpenStack gerrit 456291 None None None 2017-05-22 16:14:44 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Thierry Vignaud 2017-04-12 15:35:58 UTC
Description of problem:
The change in https://review.openstack.org/#/c/441959/ is breaking the downstream CI because it forces the installation of openstack-kolla on the undercloud.
However we won't ship openstack-kolla in RHOSP.
So this should not be mandatory but optional. Or not done by default.
All our CIs fails with:
Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-kolla' returned 1: Error: Nothing to do

See eg: https://thirdparty-logs.rdoproject.org/jenkins-osp-rhos-12-promote-puddle-virtbasic-1ctlr_1comp_64gb-11/undercloud/home/stack/undercloud_install.log.gz#_2017-04-12_03_31_10

Version-Release number of selected component (if applicable): 7.0.0-0.20170404000855.32620c5.el7ost


How reproducible:
Always

Steps to Reproduce:
1. try to deploy the undercloud from latest puddle
2.
3.

Actual results:
Fail to deploy because of missing openstack-kolla

Expected results:
Deployment should succeed as with previous puddle

Additional info:

Comment 1 Martin André 2017-04-12 17:06:40 UTC
I've submitted two patches upstream that should allow us to disable the install of openstack-kolla on the undercloud: https://review.openstack.org/#/q/topic:optional-kolla

Comment 6 Omri Hochman 2017-10-26 19:50:25 UTC
unable to reproduce with puddle : OpenStack-12.0-RHEL-7 Puddle: 2017-10-24.3

Comment 9 errata-xmlrpc 2017-12-13 21:23:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.