Bug 1441791 - cpu-partitioning: systemd error when applying CPUAffinity=
cpu-partitioning: systemd error when applying CPUAffinity=
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
:
Depends On:
Blocks: 1394932
  Show dependency treegraph
 
Reported: 2017-04-12 13:59 EDT by Luiz Capitulino
Modified: 2017-08-01 08:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: tuned-2.8.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 08:35:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luiz Capitulino 2017-04-12 13:59:14 EDT
Description of problem:

When booting latest RHEL7.4 I see in dmesg:

[    4.768508] systemd[1]: [/etc/systemd/system.conf:60] Failed to parse CPU affinity '0,2,4,6,8,10,12,14'
[    4.778995] systemd[1]: Failed to parse file '/etc/systemd/system.conf': Bad message

I see this twice, which probably means CPUAffinity= is not being applied at all.


Version-Release number of selected component (if applicable): tuned-2.8.0-1.el7 systemd-219-32.el7.x86_64


How reproducible:


Steps to Reproduce:
1. Install the cpu-partitioning profile
2. Set it up, active and reboot
Comment 2 Luiz Capitulino 2017-04-12 14:00:40 EDT
Already fixed on upstream:

commit 3023c9e86090508602d9b9d55dcc94cef3cf9e7c
Author: Jaroslav Škarvada <jskarvad@redhat.com>
Date:   Tue Apr 11 19:28:59 2017 +0200

    systemd: added support for older systemd CPUAffinity syntax
Comment 3 Jaroslav Škarvada 2017-04-12 14:04:35 EDT
(In reply to Luiz Capitulino from comment #2)
> Already fixed on upstream:
> 
> commit 3023c9e86090508602d9b9d55dcc94cef3cf9e7c
> Author: Jaroslav Škarvada <jskarvad@redhat.com>
> Date:   Tue Apr 11 19:28:59 2017 +0200
> 
>     systemd: added support for older systemd CPUAffinity syntax

Thanks for info. I would like to do respin.
Comment 7 Luiz Capitulino 2017-04-18 10:22:01 EDT
When using tuned-2.8.0-2.el7, I can see that the systemd configuration file doesn't contain commas and I don't see any systemd error on dmesg. So, this issue is fixed.
Comment 8 Tereza Cerna 2017-04-20 08:13:11 EDT
@Luiz: Thank you for your testing.

Switching to VERIFIED (SanityOnly) status based on successful test by lcapitulino.
Comment 9 errata-xmlrpc 2017-08-01 08:35:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2102

Note You need to log in before you can comment on or make changes to this bug.