Bug 144180 - Node panics while cluster membership is being formed.
Node panics while cluster membership is being formed.
Status: CLOSED DUPLICATE of bug 133512
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 17:00 EST by Dean Jansa
Modified: 2009-04-16 15:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2005-01-04 17:00:14 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) 
 
Description of problem: 
Node paniced while forming a cluster membership after a custer had 
been up and quorate on a set of nodes.  
 
modprobe cman 
modprobe dlm 
 
ccsd 
cman_tool join 
fence_tool join 
clvmd 
killall clvmd 
fence_tool leave 
cman_tool leave 
killall ccsd 
 
ccsd 
cman_tool join 
 
Hit: lm: closing connection to node 3 
dlm: closing connection to node 4 
dlm: closing connection to node 5 
dlm: closing connection to node 6 
Attempt to re-add node with id 4 
existing node is tank-06 
new node is tank-03 
------------[ cut here ]------------ 
kernel BUG at 
/usr/src/build/498825-i686/BUILD/smp/src/membership.c:244! 
invalid operand: 0000 [#1] 
SMP 
Modules linked in: dlm(U) cman(U) md5 ipv6 parport_pc lp parport 
autofs4 sunrpc e1000 microcode dm_mod uhci_hcd ehci_hcd button 
battery ac ext3 jbd qla2300 qla2xxx scsi_transport_fc sd_mod 
scsi_mod 
CPU:    1 
EIP:    0060:[<f89e8bf1>]    Tainted: GF     VLI 
EFLAGS: 00010212   (2.6.9-1.906_ELsmp) 
EIP is at add_new_node+0x2a7/0x378 [cman] 
eax: f89f1416   ebx: f5c67520   ecx: f5d9bef8   edx: f5ca07a0 
esi: f89f13de   edi: 00000004   ebp: f7da4280   esp: f5d9befc 
ds: 007b   es: 007b   ss: 0068 
Process cman_memb (pid: 2207, threadinfo=f5d9b000 task=f5d9d8f0) 
Stack: 00000000 00000006 f89fd6c4 f89fd6a0 f89fd6c4 00000014 
f89fd6b4 f89e8dac 
       00000004 00000001 c2312100 f89fd6a0 f5d9bf7c f5d9bf84 
f89e95ef 0000002c 
       c23c4820 00000000 f7de7a80 f89fd6a0 0000002c f5d9bf84 
f5d9bf7c f89e7f50 
Call Trace: 
 [<f89e8dac>] add_node_from_starttrans+0x30/0x97 [cman] 
 [<f89e95ef>] do_process_starttrans+0x236/0x2c7 [cman] 
 [<f89e7f50>] do_membership_packet+0x134/0x1c0 [cman] 
 [<f89ea3b8>] dispatch_messages+0x85/0xb2 [cman] 
 [<f89e6e88>] membership_kthread+0x231/0x3b3 [cman] 
 [<c011cea3>] default_wake_function+0x0/0xc 
 [<f89e6c57>] membership_kthread+0x0/0x3b3 [cman] 
 [<c01041f1>] kernel_thread_helper+0x5/0xb 
Code: a1 cc e2 9f f8 5f 8b 54 24 20 8b 04 90 ff 70 08 68 01 14 9f f8 
e8 36 80 73 c7 59 5b ff 75 08 68 16 14 9f f8 e8 27 80 73 c7 58 5a 
<0f> 0b f4 00 26 14 9f f8 b8 c0 e2 9f f8 e8 01 c2 8d c7 a1 cc e2 
 <0>Fatal exception: panic in 5 seconds 
Kernel panic - not syncing: Fatal exception 
 
 
 
 
 
Version-Release number of selected component (if applicable): 
CMAN <CVS> (built Dec 20 2004 13:56:40) installed  
DLM <CVS> (built Dec 20 2004 14:25:12) installed   
Kernel 2.6.9-1.906_ELsmp on an i686  
 
How reproducible: 
Didn't try 
 
Steps to Reproduce: 
1. See above 
 
 
Additional info:
Comment 1 Corey Marthaler 2005-01-05 18:35:25 EST
I hit this as well.
Comment 2 Christine Caulfield 2005-01-06 11:54:55 EST
This is related (or even identical to) 133512
Comment 3 Christine Caulfield 2005-01-10 04:21:43 EST
This is the same as 133512, the BUG() it's hitting is the one I
specifically put in to help find it.

*** This bug has been marked as a duplicate of 133512 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.