Bug 144181 - dlm module: no version for "kcl_register_service" found: kernel tainted.
Summary: dlm module: no version for "kcl_register_service" found: kernel tainted.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: dlm (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On: 145358
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-04 22:08 UTC by Derek Anderson
Modified: 2009-04-16 20:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 16:32:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2005-01-04 22:08:22 UTC
Description of problem:
The first time the dlm module is modprobed a kernel tainted message is
produced.

"dlm: no version for "kcl_register_service" found: kernel tainted."

Version-Release number of selected component (if applicable):
6.1 RPMS produced Wed 15 Dec 2004 01:13:08 PM CST

How reproducible:


Steps to Reproduce:
1. boot
2. modprobe dlm
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Adam "mantis" Manthei 2005-01-05 19:27:04 UTC
I've seen these problems too while using the rpms.  I don't think that
this is a packaging issue... it might be a kernel issue.  I've not
been able to recreate this problem 100% of the time.  I've also seen
the following message while loading the gfs module (when lock_harness
wasn't already loaded):

    gfs: no version for "lm_mount" found: kernel tainted.

Comment 2 Chris Feist 2005-01-05 20:35:13 UTC
I think the issue is in RHEL3 & FC3 you can include
/lib/modules/<kern-version>/build, but in RHEL-4 you need kernel-devel
package & the files are in /lib/modules/<kern-version>.  I'm working
on the build scripts for the kernel rpms so they put things in the
right spot (ie. /lib/modules/<kern-version>/cluster instead of in
/lib/modules/<kern-version>/build/cluster).

I've also noticed that you only get the tainted message the first time
you modprobe a module with a problem.  It seems like once the kernel's
tainted there's no un-tainting.  (Which is why you only see one 'no
version for "xxx"' messages).

Comment 3 Adam "mantis" Manthei 2005-01-05 21:03:44 UTC
Nevermind... I'm going to blame Chris again.  I can get it everytime
now just as Derek was before (I think the reason I couldn't was
because /etc/rc.sysinit was trying to automatically mount my gfs
filesystems):

[root@trin-01 ~]# dmesg -c > /dev/null

[root@trin-01 ~]# uname -r
2.6.9-1.906_EL

[root@trin-01 ~]# insmod
/lib/modules/2.6.9-1.906_EL/kernel/cluster/cman.ko 

[root@trin-01 ~]# dmesg -c
CMAN <CVS> (built Dec 22 2004 18:41:50) installed
NET: Registered protocol family 30

[root@trin-01 ~]# insmod
/lib/modules/2.6.9-1.906_EL/kernel/cluster/dlm.ko 

[root@trin-01 ~]# dmesg -c
dlm: no version for "kcl_register_service" found: kernel tainted.
DLM <CVS> (built Dec 22 2004 18:42:03) installed

Comment 4 Chris Feist 2005-01-18 18:59:45 UTC
Currently waiting on bug #145358.

Comment 5 Chris Feist 2005-01-25 23:32:36 UTC
This bug has been fixed in dlm-kernel-2.6.9-11.3 & cman-kernel-2.6.9-13.1.

Comment 6 Derek Anderson 2005-01-31 16:32:42 UTC
Verified in dlm-kernel-2.6.9-14.1 and cman-kernel-2.6.9-15.1.


Note You need to log in before you can comment on or make changes to this bug.