Bug 1441844 - Need dark variant of logo
Summary: Need dark variant of logo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-background-logo
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1439326 (view as bug list)
Depends On:
Blocks: F26BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-04-12 21:26 UTC by Paul W. Frields
Modified: 2017-06-19 20:19 UTC (History)
6 users (show)

Fixed In Version: gnome-shell-extension-background-logo-3.24.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-09 19:21:57 UTC
Type: Bug


Attachments (Terms of Use)
Patch for gschema defaults (907 bytes, patch)
2017-04-12 21:26 UTC, Paul W. Frields
no flags Details | Diff

Description Paul W. Frields 2017-04-12 21:26:44 UTC
Created attachment 1271268 [details]
Patch for gschema defaults

The F26 background coloration at bottom right means the white variant of the Fedora logo isn't visible.  A simple GSchema defaults change fixes this.  Attaching a patch that fixes this in Rawhide + F26.

Comment 1 Florian Müllner 2017-04-20 14:44:35 UTC
There weren't any replies on https://bugzilla.redhat.com/show_bug.cgi?id=1439326, is the Fedora design team behind that change?

(The white-on-nearly-white text clearly doesn't work, but that doesn't imply that we want a text+logo image instead of text-only ...)

Comment 2 Paul W. Frields 2017-04-20 18:42:26 UTC
It is indeed to point to /usr/share/pixmaps/fedora-logo.png instead of _whitelogo.  That's what the design team suggested, see https://pagure.io/design/issue/510 for reference.

Comment 3 Paul W. Frields 2017-04-20 18:43:26 UTC
*** Bug 1439326 has been marked as a duplicate of this bug. ***

Comment 4 Florian Müllner 2017-04-21 12:42:17 UTC
(In reply to Paul W. Frields from comment #2)
> That's what the design team suggested, see
> https://pagure.io/design/issue/510 for reference.

Ah, I wasn't aware of that issue (too many places for filing stuff) - apparently Ryan has similar concerns as myself (https://pagure.io/design/issue/510#comment-437572), so let's wait until we know for sure what icon to use.

Comment 5 Fedora Blocker Bugs Application 2017-05-18 13:10:45 UTC
Proposed as a Freeze Exception for 26-beta by Fedora user sgallagh using the blocker tracking app because:

 This is a low-risk change providing improved visual polish.

Comment 6 Máirín Duffy 2017-05-18 17:15:20 UTC
Hi Florian, here's the updated SVG (from the pagure ticket) that Sam produced this morning. This is tested to work across all the newly updated backgrounds (we're having the backgrounds package updated too.)

https://pagure.io/design/issue/raw/files/8f36439fb0fb31f3d5f1fd83a3ce57a622e831c4bc52570c4da419d3b4bbdb3f-fedora_blue38.svg

Comment 7 Florian Müllner 2017-05-18 20:56:50 UTC
(In reply to Máirín Duffy from comment #6)
> Hi Florian, here's the updated SVG [...]
> 
> https://pagure.io/design/issue/raw/files/
> 8f36439fb0fb31f3d5f1fd83a3ce57a622e831c4bc52570c4da419d3b4bbdb3f-
> fedora_blue38.svg

Can we get an updated fedora-logos package with that? So far we aren't shipping any artwork with the extension itself (or the package), which keeps its licenses simple ...

Comment 8 Petr Schindler 2017-05-22 16:55:17 UTC
Discussed at 2017-05-22 blocker review meeting: [1]. 

This bug was accepted as Freeze Exception: This would be good to get pulled in for Beta.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-05-22

Comment 9 Máirín Duffy 2017-05-23 18:30:52 UTC
I talked to spot and he'll package it in fedora-logos and it'll reside at /usr/share/fedora-logos/fedora_lightbackground.svg

Is there anything else you need for this Florian?

Comment 10 Fedora Update System 2017-05-23 19:17:47 UTC
fedora-logos-26.0.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-34e4f69347

Comment 11 Máirín Duffy 2017-05-25 19:14:22 UTC
Here's a summary of the packages that will fix this:

- fedora-logos
- f26-backgrounds
- gnome-shell-extension-background-logo

Here's the versions of those packages needed:

- fedora-logos-26.0.1-1.fc26
- f26-backgrounds-26.2.2-1.fc26
- **we need an updated version of gonme-shell-extension-background-logo**
  - it should reference /usr/share/fedora-logos/fedora_lightbackground.svg

Bodhi links to submitted updates, both are in testing. fedora-logos needs one more +1 for karma, f26-backgrounds has enough karma but hasn't been pushed to stable yet:

https://bodhi.fedoraproject.org/updates/fedora-logos-26.0.1-1.fc26
https://bodhi.fedoraproject.org/updates/f26-backgrounds-26.2.2-1.fc26

Since these all depend on each other nirik suggested a buildroot override to push them together.

Comment 12 Fedora Update System 2017-05-25 19:19:15 UTC
fedora-logos-26.0.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-34e4f69347

Comment 13 Paul W. Frields 2017-05-25 21:03:02 UTC
@Florian, I filed https://pagure.io/background-logo-extension/pull-request/6 with the change needed for the upstream.  (The opacity change in the gschema xml is because the SVG on disk has its own transparency built in, this was intentional AIUI.)

Comment 14 Paul W. Frields 2017-05-30 15:36:16 UTC
This bug appears to be ON_QA but that doesn't seem like the right stage. Yes, we have the new logos and backgrounds, but the actual package against which this bug is filed is still waiting for a fix (see comment #13).  I'm moving back to POST because there's a fix posted upstream.

Comment 15 Fedora Update System 2017-06-01 17:14:19 UTC
gnome-shell-extension-background-logo-3.24.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa83308938

Comment 16 Fedora Update System 2017-06-03 17:39:16 UTC
fedora-logos-26.0.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2017-06-04 19:39:23 UTC
gnome-shell-extension-background-logo-3.24.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa83308938

Comment 18 Fedora Update System 2017-06-09 19:21:57 UTC
gnome-shell-extension-background-logo-3.24.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.