Bug 1441941 - VDSM reports pivot complete and engine fails to mark the snapshot to be complete.
Summary: VDSM reports pivot complete and engine fails to mark the snapshot to be compl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ala Hino
QA Contact: Avihai
URL:
Whiteboard:
Depends On: 1509675
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-13 07:02 UTC by Ribu Tho
Modified: 2021-03-11 15:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-15 17:41:54 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3000921 0 None None None 2017-04-13 07:25:05 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:43:01 UTC

Description Ribu Tho 2017-04-13 07:02:30 UTC
Description of problem:

A snapshot job is selected to be deleted from RHV GUI . It errors on the host end and then completes . The completion never reaches engine and is lost in transmission for which snapshot still shows up . The 2nd issue for snapshot deletion causes stale entries and reports errors as such in engine event logs

Message: Failed to delete snapshot '<UNKNOWN>' for VM 'redhatguest'.
 

Version-Release number of selected component (if applicable):

ovirt-engine-4.0.3-0.1.el7ev.noarch
vdsm-4.18.11-1.el7ev.x86_64

How reproducible:


Steps to Reproduce:

1. Create a snapshot 
2. Delete the  snapshot
3. host errors 1st time for "libvirtError: block copy still active: disk 'vda' not ready for pivot yet"
4. Operation completes and pivots on host end .
5. Engine fails to get this info and snapshot still shows up.
 
Actual results:

- The snapshot doesn't complete.
- Requires to run it again 
- Causes stale entries in the command_entities table that keeps retrying the snapshot removal job.

Expected results:

- Engine waits for the process to complete and marks the snapshot to be complete. 


Additional info:

Comment 5 Ala Hino 2017-04-19 09:55:42 UTC
Re-opening the bug and marking it as depends on BZ 1438850 that describes the same issue.

Comment 6 Allon Mureinik 2017-06-13 13:20:02 UTC
(In reply to Ala Hino from comment #5)
> Re-opening the bug and marking it as depends on BZ 1438850 that describes
> the same issue.
Bug 1438850 is already verified. Moving to MODIFIED

Comment 13 RHV bug bot 2017-12-06 16:15:16 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 14 RHV bug bot 2017-12-12 21:14:05 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 15 Avihai 2017-12-14 08:46:41 UTC
verified (Same verification as bug 1509675)

Passed automation run with:
rhvm-4.2.0.2-0.1.el7.noarch
vdsm-4.20.9.1-1.el7ev.x86_64
libvirt-3.2.0-14.el7_4.5.x86_64

Comment 16 RHV bug bot 2017-12-18 17:04:38 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 19 errata-xmlrpc 2018-05-15 17:41:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 20 Franta Kust 2019-05-16 13:04:31 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.