Bug 144207 - ChangeEmailAction has hard coded text
ChangeEmailAction has hard coded text
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ken Ganong
Vlady Zlatkin
:
: 145785 (view as bug list)
Depends On:
Blocks: 151514
  Show dependency treegraph
 
Reported: 2005-01-04 20:54 EST by Mike McCune
Modified: 2007-04-18 13:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 16:55:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2005-01-04 20:54:18 EST
This should be localized:

  
    /**
     * Sends out a verification email to the given address.
     * @param addr The email address to which the email should be sent.
     */
    private void sendVerificationEmail(String addr) {
        Mail mailer = new SmtpMail();
        mailer.setRecipients(new String[] { addr });
        mailer.setSubject("Email Verification");
        mailer.setBody("This is a test");
        mailer.send();
    }
Comment 1 Mike McCune 2005-03-02 14:24:37 EST
*** Bug 145785 has been marked as a duplicate of this bug. ***
Comment 2 Ken Ganong 2005-05-31 17:11:57 EDT
There were much larger issues here.  We needed the correct email text for one,
including generating a url for verification.  Also, the current code did not
take into account the differences for satellite in the perl code.
Comment 3 Jesus M. Rodriguez 2005-06-10 14:33:38 EDT
Mass moving ON_DEV to ON_QA
Comment 4 Beth Nackashi 2005-07-05 16:02:20 EDT
This doesn't look like it should be ON_QA; at the very least there should be
some sort of test plan.
Comment 5 Ken Ganong 2005-07-05 16:17:23 EDT
TEST PLAN
Login as an org admin on hosted.
Go to users->click a user->confirm email address.
change the email address and then click send verification.
A verification email should be sent.

confirm that this email has a more interesting body than "this is a test",
account information, and a hashed url for verification.  Confirm that the url
has the correct host name and is either http or https accordingly.

On satellite there should be no "confirm" for email address... simply "change".
No email should be sent in a satellite setting.
Comment 6 Vlady Zlatkin 2005-07-05 17:39:31 EDT
looks good
Comment 7 Vlady Zlatkin 2005-07-05 17:44:14 EDT
its coming from dev-null@rhn.redhat.com, is that intentional?
Comment 8 Jesus M. Rodriguez 2005-07-05 17:57:42 EDT
That is the default value as defined by the web.default_mail_from configuration
variable.  If you would like it to be from someone else, override the above 
entry in /etc/rhn/rhn.conf.  

This is the current value in /etc/rhn/default/rhn_web.conf:

web.default_mail_from = Red Hat Network <dev-null@rhn.redhat.com>
Comment 9 Jesus M. Rodriguez 2005-07-05 17:58:13 EDT
Moving back to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.