Bug 1442084 - Legacy hiera hook or data has been detected error fails deployment
Summary: Legacy hiera hook or data has been detected error fails deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat-agents
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Steve Baker
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-13 13:26 UTC by Gurenko Alex
Modified: 2017-05-17 20:22 UTC (History)
5 users (show)

Fixed In Version: openstack-heat-agents-1.0.1-1.el7ost openstack-tripleo-common-6.0.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:22:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 455150 None None None 2017-04-13 13:43:54 UTC
Launchpad 1680996 None None None 2017-04-13 13:43:30 UTC

Description Gurenko Alex 2017-04-13 13:26:15 UTC
Description of problem: with latest build of 2017-04.12.4 deployment is failing with following error message:

overcloud.DB.0.DBDeployment:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: d5919af6-7426-495a-82ba-7d0e74f2f2f2
  status: CREATE_FAILED
  status_reason: |
    Error: resources.DBDeployment: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 1
  deploy_stdout: |

  deploy_stderr: |
    Legacy hiera hook or data has been detected. Please update all of your interfaces to use the new heat-agents hiera hook before proceeding. See http://lists.openstack.org/pipermail/openstack-dev/2017-January/110922.html or bug 1680006 for more information.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Try deploying any topology
2.
3.

Actual results:

Overcloud deployment fails with error message above


Expected results:

Deployment completes successfully


Additional info:

Tested on simple 1:1:1 (Compute:Controller:Ceph) deployment and composable role.
Seems like similar to this bug regarding upgrade proceedure: https://bugzilla.redhat.com/show_bug.cgi?id=1439121

Comment 2 Red Hat Bugzilla Rules Engine 2017-04-13 13:42:03 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 9 Gurenko Alex 2017-04-18 09:27:09 UTC
Verified on 2017-04-17.2 build

Comment 10 errata-xmlrpc 2017-05-17 20:22:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.