Bug 144213 - Bug: Assertion (heads < 256) at disk_dos.c:486 in function probe_partition_for_geom() failed
Bug: Assertion (heads < 256) at disk_dos.c:486 in function probe_partition_fo...
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 21:17 EST by Tony Adams
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This file was written to floppy by the bug catcher within anaconda (720.79 KB, text/plain)
2005-01-04 21:18 EST, Tony Adams
no flags Details

  None (edit)
Description Tony Adams 2005-01-04 21:17:05 EST
Description of problem:

Each time the installation program reads from the hard disks this 
error comes up (Bug: Assertion (heads < 256) at disk_dos.c:486 in 
function probe_partition_for_geom() failed).  I can Ignore or Cancel 
past it, but it will cause the install to abort when I try to load 
the packages.

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:

1.Boot from install CD
2.Select language and keyboard layout (US. English)
3.Window pops up "Bug: Assertion (heads < 256) at disk_dos.c:486 in 
function probe_partition_for_geom() failed
4.Click Ignore or Cancel 4 times (there doesn't seem to be any 
functional difference) and I'm presented with the Installation Type 
screen.
5.Choose Workstation
6.Choose automatic or manual partitioning and the error is back(Bug: 
Assertion (heads < 256) at disk_dos.c:486 in function 
probe_partition_for_geom() failed)
7.6 clicks clear it and I can tell it which drive to install to.
8.Once the drive is selected and I agree to wipe out the data on the 
drive the error returns again.
9.2 clicks clear it and the install appears to move on
10.setu pgrub, network, firewall, language, time zone, and set root 
password
11.choose to install default (or custom) packages
12.click through box indicating which disks I'll need
13.error is back, three clicks of the cancel button get me a new 
window "An Exception Occurred" I'm given the opportunity to save a 
bunch of info to floppy disk and I'm asked to report the bug to this 
site.
  
Actual results:

Install fails

Expected results:

Successful install

Additional info:

Athlon XP1600+, 512MB RAM
ECS K7S5A motherboard
Comment 1 Tony Adams 2005-01-04 21:18:56 EST
Created attachment 109353 [details]
This file was written to floppy by the bug catcher within anaconda
Comment 2 Jeremy Katz 2005-01-04 21:20:20 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 3 John Igoe 2005-02-03 18:24:30 EST
I received the same bug but also received several others:
BUG
Assertion((C * heads + H) * sectors + S==A) at disk_dos.c:495 in 
function probe_partition_for_geom() failed.

BUG
Assertion(heads > 0) at disk_dos.c:485 in function 
probe_partition_for_geom() failed.

BUG
Assertion(sectors <= 63) at disk_dos.c:490 in function 
probe_partition_for_geom() failed.

I am running a Dell PIII with 90GB & 40GB hard drives.
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.