Bug 144231 - CAN-2004-1125 kpdf buffer overflows (CAN-2005-0064)
Summary: CAN-2004-1125 kpdf buffer overflows (CAN-2005-0064)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdegraphics
Version: 4.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard: impact=important,public=20041221
Keywords: Security
Depends On:
Blocks: 142822
TreeView+ depends on / blocked
 
Reported: 2005-01-05 03:01 UTC by Josh Bressers
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-02-15 10:18:15 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2005:066 normal SHIPPED_LIVE Important: kdegraphics security update 2005-02-15 05:00:00 UTC

Description Josh Bressers 2005-01-05 03:01:41 UTC
*** This bug has been split off bug 144197 ***

iDEFENSE has reported a buffer overflow issue in xpdf 3.  This issue
also affects the xpdf in RHEL3.

http://www.idefense.com/application/poi/display?id=172&type=vulnerabilities&flashstatus=true

The advisory references a patch to fix this issue.


kpdf contains the xpdf code.

Comment 1 Mark J. Cox 2005-01-26 11:04:00 UTC
Additionally a second buffer overflow was found in xpdf which affects
kpdf, see http://www.kde.org/info/security/advisory-20050119-1.txt


Comment 2 Mark J. Cox 2005-02-15 10:18:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2005-066.html



Note You need to log in before you can comment on or make changes to this bug.