Bug 144241 - Devlabel fails to recognise SCSI drives
Devlabel fails to recognise SCSI drives
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: devlabel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2005-01-05 03:48 EST by Kevin Haines
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 20:18:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for this and other issues (3.10 KB, patch)
2005-01-06 17:35 EST, Bill Nottingham
no flags Details | Diff
fix for devlabel-fixes.patch (3.10 KB, patch)
2005-01-07 10:24 EST, Phillip Sorensen
no flags Details | Diff
new patch (3.10 KB, patch)
2005-01-07 12:36 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Kevin Haines 2005-01-05 03:48:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007

Description of problem:
This version of devlabel will not identify the SCSI drives that exist
on my system. This may be due to the output of scsi_unique_id being
different between the two packages.

Rolling back to version 0.42 of the package has fixed the problem for now.

Version-Release number of selected component (if applicable):
0.48.03-6

How reproducible:
Always

Steps to Reproduce:
1. Set up devlabel 0.42 to symlink to a SCSI disk.
2. 'devlabel reload'
3. Link is OK
4. Upgrade to devlabel 0.48
5. 'devlabel reload'
6. Link is removed, devlabel doesn't see SCSI disk.
    

Actual Results:  Lost symlink to SCSI devices.

Expected Results:  Devlabel should have created symlinks.

Additional info:
Comment 1 Bill Nottingham 2005-01-05 14:05:08 EST
What is the difference in the output of scsi_unique_id between the two
packages?
Comment 2 Phillip Sorensen 2005-01-05 17:05:48 EST
I am having the same problem on the x86_64 platform.  I noticed that
the new version of devlabel puts a space in the id.  It appears to be
between the two page 83 type 3 lines from scsi_unique_id.

The output of my scsi unique id is:

model: IFT     A16F-R1211
page80: 30303030303236383043314541333030
page83 type3: 600d023000656767000002680c1ea300
page83 type3: 200000d023600002
page83 type0: 1100000000656767000000000000000000000000

the output from devlabel printid:

devlabel 0.42:
S83.3:600d023000656767000002680c1ea300200000d023600002IFTA16F-R1211sector63

devlabel 0.48:
S83.3:600d023000656767000002680c1ea300
200000d023600002IFTA16F-R1211sector63



I noticed in the code that the 'tr -d "\n"' has been remove after the
sed statement.  I think this is causing the problem. See below for the
line of code from get_id()

-       if ID=`echo "$scsi_unique_id" | grep "page83 type3:" | sed
's/page83 type3: //' | tr -d "\n"` && [ -n "$ID" ]; then
+       if ID=`echo "$scsi_unique_id" | grep "page83 type3:" | sed
's/page83 type3: //'` && ID="`echo $ID`" && [ -n "$ID" ]; then

Comment 3 Phillip Sorensen 2005-01-05 17:09:07 EST
I added the tr -d "\n" back in and this fixed the problem here.
Comment 4 Kevin Haines 2005-01-06 08:07:12 EST
Bill, sorry I can't regenerate the 0.48 output because it's a
production system and I needed to get it running; so I'm stuck with
0.42 for now.

Phillip, thanks for the fix, I will try this during the next system
downtime.

Cheers

Kevin
Comment 5 Bill Nottingham 2005-01-06 17:35:53 EST
Created attachment 109446 [details]
patch for this and other issues

Does this work for you?
Comment 6 Kevin Haines 2005-01-07 03:17:36 EST
Bill,

Will try the patch during next scheduled downtime on 12th Jan.

Many thanks

Kevin
Comment 7 Phillip Sorensen 2005-01-07 10:24:41 EST
Created attachment 109472 [details]
fix for devlabel-fixes.patch

After I fixed a missing ` in the patch, it worked for me.  The new patch
corrects this.
Comment 8 Bill Nottingham 2005-01-07 12:36:11 EST
Created attachment 109479 [details]
new patch

Actually, you want to remove the other backtick.
Comment 9 Bill Nottingham 2005-01-07 12:37:07 EST
Thanks for spotting that, BTW.
Comment 10 Phillip Sorensen 2005-01-10 15:42:02 EST
New patch works here.
Comment 11 Kevin Haines 2005-01-12 02:54:17 EST
New patch works, many thanks.
Comment 12 Tim Powers 2005-05-19 20:18:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-121.html

Note You need to log in before you can comment on or make changes to this bug.