Bug 144249 - telnet does not pass on Umlauts
Summary: telnet does not pass on Umlauts
Status: CLOSED DUPLICATE of bug 144248
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: telnet (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-05 11:58 UTC by Steffen Mann
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 12:33:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steffen Mann 2005-01-05 11:58:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041115 Firefox/1.0

Description of problem:
telnet client and server are both the above version both fully up2date
RHEL3 systems.

/etc/sysconfig/i18n:

LANG="de_DE.UTF8"   #"en_US.UTF-8"
SUPPORTED="de_DE.UTF-8:de_DE:en_GB.UTF-8:en_GB:en:en_US.UTF-8:en_US:en:en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

on the Server side:

LANG="de_DE.UTF-8"
SUPPORTED="en_GB.UTF-8:en_GB:en:de_DE.UTF-8:de_DE:de"
SYSFONT="latarcyrheb-sun16"


However this should not matter the telnet client does not take the
caracters like ����� and pass them on the the server during a normal
logon scession.


Version-Release number of selected component (if applicable):
telnet-0.17-26

How reproducible:
Always

Steps to Reproduce:
1.telnet ip
2. log on a user
3. type caracter like ������ 
    

Actual Results:  diffrent caracters than the expected ones.

Expected Results:  Should pass on these typed caracters.

Additional info:

Tested on two RHEL3 fully up2date systems.

Comment 1 Steffen Mann 2005-01-05 12:07:07 UTC
The weird looking characters should be german umlauts like the special
characters for ae oe ue and sz.

Comment 2 Bastien Nocera 2005-01-05 12:33:18 UTC

*** This bug has been marked as a duplicate of 144248 ***


Note You need to log in before you can comment on or make changes to this bug.