Bug 1442540 - Accessing subscription page as non-admin user hangs
Summary: Accessing subscription page as non-admin user hangs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: pre-dev-freeze
: 7.6
Assignee: Martin Pitt
QA Contact: Jan Ščotka
URL:
Whiteboard:
: 1366092 (view as bug list)
Depends On:
Blocks: 1400961 1472751 1589370 ovirt-node-ng-platform ovirt-node-ng-43-el76-platform
TreeView+ depends on / blocked
 
Reported: 2017-04-15 09:45 UTC by Yihui Zhao
Modified: 2018-10-30 10:35 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:34:55 UTC


Attachments (Terms of Use)
subscriptions_page.png (32.46 KB, image/png)
2017-04-15 09:45 UTC, Yihui Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3148 None None None 2018-10-30 10:35:46 UTC

Description Yihui Zhao 2017-04-15 09:45:12 UTC
Created attachment 1271778 [details]
subscriptions_page.png

Description of problem:
When the gerenal user access the subscription page via cockpit, it keeps "retrieving subscription status, updating"


Version-Release number of selected component (if applicable):
rhvh-4.1-0.20170413.0+1
cockpit-storaged-135-4.el7.noarch
cockpit-bridge-135-4.el7.x86_64
cockpit-ws-135-4.el7.x86_64
cockpit-system-135-4.el7.noarch
cockpit-ovirt-dashboard-0.10.7-0.0.16.el7ev.noarch



How reproducible:
100%

Steps to Reproduce:
1.Install RHVH4.1
2. Login cockpit with root user, set the node user password, logout out
3. Login cockpit with node user, check the subscription page.


Actual results:
After step3, the subscription page keeps "retrieving subscription status,updateing".

Expected results:
The general user don't have access to check the subscription status, should give a warning.

Additional info:

Comment 1 Ryan Barry 2017-04-15 14:56:44 UTC
Note that the "node" user works with "{superuser: try}"

Comment 3 Martin Pitt 2018-01-23 12:17:06 UTC
Confirmed that this is still happening with master.

Comment 4 Martin Pitt 2018-01-23 12:32:51 UTC
*** Bug 1366092 has been marked as a duplicate of this bug. ***

Comment 5 Martin Pitt 2018-01-23 14:53:07 UTC
Fix sent to https://github.com/cockpit-project/cockpit/pull/8475

Comment 9 errata-xmlrpc 2018-10-30 10:34:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3148


Note You need to log in before you can comment on or make changes to this bug.