Bug 144267 - external bug reference requires additional boolean search fields
external bug reference requires additional boolean search fields
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 08:42 EST by James Laska
Modified: 2013-09-02 02:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 15:42:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-01-05 08:42:23 EST
With the addition of the external bug reference, users now need a way to find
all bugs pertaining to a particular bug system AND specific bug numbers in
another bug system.  We talked about this but I never filed it yet.  I think we
decided that we need 2 values to search on:

1) External Bug System *
2) External Bug ID

* the external bug system would be perfect as a drop-down list, however the
boolean search doesn't allow for that.  This means the user will need to be able
to find what to enter (either the title for the bug system, or the URL).  

Perhaps we create a new column in the external_bugzilla table called:

  code VARCHAR(10) UNIQ

This will allow you to enter a character code to assign to each system (similar
to the values discussed on an internal mailing list about the MZ#123124,
XM#123112, LTC#23412 format where the codes would be MZ, XM, LTC respectively).
 This code would then be used as the search value in the boolean query "External
Bug System Code."  We still of course need a way for users to find out what the
code is in order to use it (or they can just do a showbug.cgi and look at the
values).

The alternative is to have "External Bug System" just to a string comparison on
the description column in the external_bugzilla table.

Thoughts?
Comment 1 David Lawrence 2005-01-05 13:05:29 EST
(In reply to comment #0)
> 1) External Bug System *
> 2) External Bug ID
> 

Agreed.

 > The alternative is to have "External Bug System" just to a string comparison on
> the description column in the external_bugzilla table.

I kind of like the last option you stated. Not because it would be easier (it
would actually) but because it seems more intuitive anyway. For instance you
just select search on External Bug System, then choose the search type of Sounds
Like or similar, and then type in Gnome, Samba, or Redhat in the text field.
Otherwise if we used unique identifiers, what would they be? b.r.c for Red Hat's
Bugzilla and b.g.o for Gnomes'?  Open to suggestions on sensible naming.


Comment 2 James Laska 2005-01-05 13:07:45 EST
your solution sounds good to me
Comment 3 David Lawrence 2008-09-16 12:51:58 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Note You need to log in before you can comment on or make changes to this bug.